browser crashed after loading page [@ GetQDGlobalsBlack ]

RESOLVED DUPLICATE of bug 200511

Status

()

--
critical
RESOLVED DUPLICATE of bug 200511
15 years ago
7 years ago

People

(Reporter: cdjonah, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624

nothing more to say

Reproducible: Always

Steps to Reproduce:
1.go to www.nytimes.com
2.click on technology page
3.admire dump

Actual Results:  
 page loaded and then Mozilla crashed

Expected Results:  
Load page and let me do something about it

Date/Time:  2003-07-09 09:26:22 -0500
OS Version: 10.2.6 (Build 6L60)
Host:       anchjb.chm.anl.gov

Command:    mozilla-bin
PID:        8594

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x91a7f470 in GetQDGlobalsBlack
 #1   0x0932ad70 in 0x932ad70
 #2   0x09397ea8 in 0x9397ea8
 #3   0x09397964 in 0x9397964
 #4   0x093298d4 in 0x93298d4
 #5   0x093a8bbc in 0x93a8bbc
 #6   0x09387848 in 0x9387848
 #7   0x0938e13c in 0x938e13c
 #8   0x0939762c in 0x939762c
 #9   0x093baaec in 0x93baaec
 #10  0x09320070 in 0x9320070
 #11  0x0931f9b0 in 0x931f9b0
 #12  0x027be580 in
ns4xPluginStreamListener::OnDataAvailable(nsIPluginStreamInfo*, nsIInputStream*,
unsigned)
 #13  0x027c3518 in nsPluginStreamListenerPeer::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned)
 #14  0x006a17a0 in nsStreamListenerTee::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned)
 #15  0x007033ac in nsHttpChannel::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned)
 #16  0x00689a50 in nsInputStreamPump::OnStateTransfer()
 #17  0x00689800 in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*)
 #18  0x001f4544 in nsInputStreamReadyEvent::EventHandler(PLEvent*)
 #19  0x001a9a0c in PL_HandleEvent
 #20  0x001a9904 in PL_ProcessPendingEvents
 #21  0x001a9e04 in _md_EventReceiverProc
 #22  0x969a2c54 in DispatchEventToHandlers
 #23  0x969a2fbc in SendEventToEventTargetInternal
 #24  0x969a63d0 in SendEventToEventTargetWithOptions
 #25  0x969b2940 in ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*,
OpaqueEventRef*, void*)
 #26  0x969a2d0c in DispatchEventToHandlers
 #27  0x969a2fbc in SendEventToEventTargetInternal
 #28  0x969b5494 in SendEventToEventTarget
 #29  0x969b7258 in ToolboxEventDispatcher(OpaqueEventRef*)
 #30  0x969c8740 in CallEventDispatchHook
 #31  0x969b3c90 in TryEventDispatcher
 #32  0x969a4570 in GetOrPeekEvent
 #33  0x969a421c in GetNextEventMatchingMask
 #34  0x969a8054 in WNEInternal
 #35  0x969adf0c in WaitNextEvent
 #36  0x00b98360 in nsMacMessagePump::GetEvent(EventRecord&)
 #37  0x00b9823c in nsMacMessagePump::DoMessagePump()
 #38  0x00b8bd00 in nsAppShell::Run()
 #39  0x000053cc in main1(int, char**, nsISupports*)
 #40  0x00005928 in main
 #41  0x00002250 in _start
 #42  0x000020d0 in start

Thread 1:
 #0   0x9002578c in select
 #1   0x002d39e0 in poll
 #2   0x002d01d0 in _pr_poll_with_poll
 #3   0x006a116c in nsSocketTransportService::Run()
 #4   0x001ac30c in nsThread::Main(void*)
 #5   0x002d163c in _pt_root
 #6   0x90020d28 in _pthread_body

Thread 2:
 #0   0x9003ea88 in semaphore_wait_signal_trap
 #1   0x9003e8a4 in _pthread_cond_wait
 #2   0x002cc7e0 in PR_WaitCondVar
 #3   0x006a9ee4 in nsDNSService::DequeuePendingQ()
 #4   0x006a9918 in nsDNSService::Run()
 #5   0x001ac30c in nsThread::Main(void*)
 #6   0x002d163c in _pt_root
 #7   0x90020d28 in _pthread_body

Thread 3:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x928ec28c in JNI_CreateJavaVM_Impl
 #3   0x928ec224 in JNI_CreateJavaVM_Impl
 #4   0x928a51fc in JVM_GetClassMethodsCount
 #5   0x90020d28 in _pthread_body

Thread 4:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x9285eae4 in JVM_FillInStackTrace
 #4   0x928647a0 in JVM_Send
 #5   0x9290114c in JNI_CreateJavaVM_Impl
 #6   0x928a51fc in JVM_GetClassMethodsCount
 #7   0x90020d28 in _pthread_body

Thread 5:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x036a8668 in 0x36a8668
 #7   0x036a668c in 0x36a668c
 #8   0x036a668c in 0x36a668c
 #9   0xa2843c38 in typeinfo name for std::bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90020d28 in _pthread_body

Thread 6:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x036a8668 in 0x36a8668
 #7   0x036a668c in 0x36a668c
 #8   0x036a65cc in 0x36a65cc
 #9   0x036a65cc in 0x36a65cc
 #10  0xa2843c38 in typeinfo name for std::bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90020d28 in _pthread_body

Thread 7:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x92844e18 in JVM_GetClassLoader
 #4   0x92844ba4 in JVM_GetClassLoader
 #5   0x928a51fc in JVM_GetClassMethodsCount
 #6   0x90020d28 in _pthread_body

Thread 8:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92903300 in JVM_InitProperties
 #5   0x92903138 in JVM_InitProperties
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90020d28 in _pthread_body

Thread 9:
 #0   0x90073c28 in mach_msg_trap
 #1   0x90005f70 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x9288890c in JVM_StartThread
 #5   0x92876c10 in JVM_FindLoadedClass
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90020d28 in _pthread_body

Thread 10:
 #0   0x90042668 in semaphore_timedwait_signal_trap
 #1   0x9003e894 in _pthread_cond_wait
 #2   0x002cc5a4 in pt_TimedWait
 #3   0x002cc7f4 in PR_WaitCondVar
 #4   0x001afd58 in TimerThread::Run()
 #5   0x001ac30c in nsThread::Main(void*)
 #6   0x002d163c in _pt_root
 #7   0x90020d28 in _pthread_body

Thread 11:
 #0   0x9003ea88 in semaphore_wait_signal_trap
 #1   0x9003e8a4 in _pthread_cond_wait
 #2   0x002cc7e0 in PR_WaitCondVar
 #3   0x001ad434 in nsThreadPool::GetRequest(nsIThread*)
 #4   0x001add00 in nsThreadPoolRunnable::Run()
 #5   0x001ac30c in nsThread::Main(void*)
 #6   0x002d163c in _pt_root
 #7   0x90020d28 in _pthread_body

Thread 12:
 #0   0x90042668 in semaphore_timedwait_signal_trap
 #1   0x9003e894 in _pthread_cond_wait
 #2   0x002cc5a4 in pt_TimedWait
 #3   0x002cc7f4 in PR_WaitCondVar
 #4   0x002ccb60 in PR_Wait
 #5   0x0724f6d0 in nsImapProtocol::ImapThreadMainLoop()
 #6   0x0724edbc in nsImapProtocol::Run()
 #7   0x001ac30c in nsThread::Main(void*)
 #8   0x002d163c in _pt_root
 #9   0x90020d28 in _pthread_body

Thread 13:
 #0   0x90042668 in semaphore_timedwait_signal_trap
 #1   0x9003e894 in _pthread_cond_wait
 #2   0x002cc5a4 in pt_TimedWait
 #3   0x002cc7f4 in PR_WaitCondVar
 #4   0x002ccb60 in PR_Wait
 #5   0x0724f6d0 in nsImapProtocol::ImapThreadMainLoop()
 #6   0x0724edbc in nsImapProtocol::Run()
 #7   0x001ac30c in nsThread::Main(void*)
 #8   0x002d163c in _pt_root
 #9   0x90020d28 in _pthread_body

PPC Thread State:
  srr0: 0x91a7f470 srr1: 0x0200f930                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x0932ad70  ctr: 0x91a7f438   mq: 0x00000000
    r0: 0xffff0000   r1: 0xbfffeb30   r2: 0x91a91910   r3: 0x00000000
    r4: 0x0005e228   r5: 0x00000020   r6: 0x00000042   r7: 0x91a7f440
    r8: 0x0000ffff   r9: 0x0000ffff  r10: 0xffff0000  r11: 0xffffffff
   r12: 0xffffffff  r13: 0x00000000  r14: 0x00000000  r15: 0xbffffec4
   r16: 0x00000002  r17: 0x00014d18  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000002  r21: 0x00000000  r22: 0x00000000  r23: 0x09d117e0
   r24: 0x084be000  r25: 0x09ba07f8  r26: 0x084b71b8  r27: 0x084be000
   r28: 0x000031f7  r29: 0x09bb6b64  r30: 0x09bb6b64  r31: 0x09bb7188

Comment 1

15 years ago
upgrade to latest Flash plug-in (as of today, 6.0r79) and reopen if still crashing.

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Browser-General → Plug-ins
Keywords: crash
Resolution: --- → DUPLICATE
Summary: browser crashed after loading page → browser crashed after loading page [@ GetQDGlobalsBlack ]
Crash Signature: [@ GetQDGlobalsBlack ]
You need to log in before you can comment on or make changes to this bug.