If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla won't start unless a URL/location is given

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Paul van Erk, Unassigned)

Tracking

1.4 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030708
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030708

Ever since Mozilla 1.2 on my Gentoo Linux system, I can't start mozilla just
like that. Typing "mozilla" results in going back to the command prompt: no
error message, mozilla-bin doesn't even start. However, if I use "mozilla
any_bit_of_text_here", it works fine.

The strange thing is, it works fine for my wife, on the same machine. After
thinking it was maybe a messed up file somewhere, I removed my .mozilla
directory and anything related to my account in /tmp. That didn't help. Tried
creating new profiles, no good. I've even created new users on my system, but
they have the same problem. The only one who can simply type "mozilla" to run
it, is my wife's account. I tried running it under KDE (my wife uses that), but
that didn't help either. It's not a biggy, my shortcut now reads "mozilla
about:blank", but it's still something annoying.

Reproducible: Always

Steps to Reproduce:
1. Install (emerge) Mozilla
2. Start it
3. See nothing :/

Actual Results:  
Nothing, mozilla didn't start. /usr/bin/mozilla starts, but /usr/bin/mozilla-bin
is the one that does nothing.

Expected Results:  
Erm, start? :)

Comment 1

14 years ago
> /usr/bin/mozilla starts, but /usr/bin/mozilla-bin

1. I *REALLY* hope you didn't install mozilla to /usr/bin

2. where did you get your build (and what format is it)?  from .mozilla.org?  is
it an RPM?

to see what's happening, first do:
% which mozilla
that will tell you which mozilla command you're actually running

% sh -x mozilla
that will print every line of the script before it's executed.
(Reporter)

Comment 2

14 years ago
#1: No, I mentioned, I'm using Gentoo Linux. The script to start Mozilla is in
/usr/bin, the rest is in /usr/lib/mozilla

#2: Again, I'm using Gentoo Linux. So Mozilla gets built from source. I didn't
have this problem until it occured with Mozilla 1.2 I believe. I've used Galeon
most of the time anyway and for my wife it has no problems. I though it'd
disappear with an upgrade, so I went to 1.3: still the same problem. And now 1.4
does it as well. It can't be a misconfiguration, 'coz new users have the same
problem. When I remove my wife's ~/.mozilla it just creates a new one and starts
up, no problems. I'm being discriminated! :D

-----
mrhankey ~ # which mozilla
/usr/bin/mozilla
-----

mrhankey ~ # sh -x mozilla
++ basename mozilla
+ cmdname=mozilla
+ ulimit -c 0
+ MOZ_DIST_BIN=/usr/lib/mozilla
+ MOZ_PROGRAM=/usr/lib/mozilla/mozilla-bin
+ MOZ_CLIENT_PROGRAM=/usr/lib/mozilla/mozilla-xremote-client
+ MOZILLA_FIVE_HOME=/usr/lib/mozilla
+ export MOZILLA_FIVE_HOME
+ '[' -f /usr/lib/mozilla/libc++mem.so ']'
+ '[' '' ']'
+ LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins
+ export LD_LIBRARY_PATH
+ export MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
+ MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
+ '[' /root ']'
+ export MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins:/root/.mozilla/plugins
+ MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins:/root/.mozilla/plugins
+ FONTCONFIG_PATH=/etc/fonts:/usr/lib/mozilla/res/Xft
+ export FONTCONFIG_PATH
+ grep -q /root/.mozilla /root/.mozilla/appreg
+ SET_LANG=0
+ '[' /root -a '' -a 0 '!=' 0 ']'
+ set_jvm_vars
+ '[' -L /usr/lib/mozilla/plugins/javaplugin_oji.so ']'
+ JVM_ORIG_LINK=/usr/lib/mozilla/plugins/javaplugin_oji.so
+ '[' -L /usr/lib/mozilla/plugins/libjavaplugin_oji.so ']'
+ JVM_ORIG_LINK=/usr/lib/mozilla/plugins/libjavaplugin_oji.so
+ '[' -z /usr/lib/mozilla/plugins/libjavaplugin_oji.so ']'
++ perl -e 'print readlink('\''/usr/lib/mozilla/plugins/libjavaplugin_oji.so'\'')'
+ JVM_LINK=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/libjavaplugin_oji.so
+ echo /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/libjavaplugin_oji.so
+ grep -e '^/'
+ '[' 0 -ne 0 ']'
++ basename /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/libjavaplugin_oji.so
+ JVM_BASE=libjavaplugin_oji.so
++ echo /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/libjavaplugin_oji.so
++ sed -e s/libjavaplugin_oji.so//g
+ JVM_DIR=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/
+ JVM_COMMAND=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610//java
+ '[' '!' -r /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610//java ']'
+ JVM_DIR=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin/
+ JVM_COMMAND=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin//java
+ '[' '!' -r /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin//java ']'
+ export LD_ASSUME_KERNEL=2.2.5
+ LD_ASSUME_KERNEL=2.2.5
++ /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin//java -version
+ JVM_VERSION=/opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin//java:
error while loading shared libraries: libpthread.so.0: cannot open shared object
file: No such file or directory
+ unset LD_ASSUME_KERNEL
++ echo /opt/sun-jdk-1.4.1.02/jre/plugin/i386/ns610/../../../bin//java: error
while loading shared libraries: libpthread.so.0: cannot open shared object file:
No such file or directory
++ grep version
++ cut -f 3 -d ' '
++ sed -e 's/\"//g'
+ JVM_VERSION=
++ check_running
++ '[' -x /usr/lib/mozilla/mozilla-xremote-client ']'
++ /usr/lib/mozilla/mozilla-xremote-client 'ping()'
++ RETURN_VAL=2
++ '[' 2 -eq 2 ']'
++ echo 0
++ return 0
+ ALREADY_RUNNING=0
+ '[' 0 -eq 1 ']'
+ '[' -z '' ']'
+ exec /usr/lib/mozilla/mozilla-bin
mrhankey ~ #

Like I said: the script starts, but mozilla-bin just exits. If I start
/usr/llib/mozilla/mozilla-bin then it exits as well.
(Reporter)

Comment 3

14 years ago
Something else: if I already have mozilla running, then it's no problem. It
doesn't start if it's not running yet AND if no URL (or any character for that
matter, even "mozilla a" does the trick) is given.

Comment 4

14 years ago
> #2: Again, I'm using Gentoo Linux. So Mozilla gets built from source.

No law requires all Gentoo folks to build everything from source...

It looks like Gentoo is using an old version of the RPM startup script.

Try this (assuming you're in bash):

mrhankey ~ # export LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins
mrhankey ~ # export MOZILLA_FIVE_HOME=/usr/lib/mozilla
mrhankey ~ # /usr/lib/mozilla/mozilla-bin

and also try the last again with a URL.
The RPM script takes a different path depending on the existence of a command
line argument.
(Reporter)

Comment 5

14 years ago
True about the Gentoo thing, of course someone could use RPM's or so. Anyway,
I'm not, I'm using build-from-source ebuilds only. Upgrading OpenOffice is a
pain, indeed. ;)

Anyway, I saw your writing and 'knew' it wouldn't work. Like I said: it works
fine for my wife starting just "mozilla". She's the only one who can do that.
Result of what you wrote: mozilla-bin just exited back to the prompt without a
url and WITH a url it starts up. It's driving me nuts, I tell ya! :D

I just tried again with a completely new, never before created user. I logged
in, opened a term, typed "mozilla" and it exited. Really, really weird...

Comment 6

14 years ago
ok, try this...

mrhankey ~ # export LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins
mrhankey ~ # export MOZILLA_FIVE_HOME=/usr/lib/mozilla
mrhankey ~ # gdb /usr/lib/mozilla/mozilla-bin
(gdb) b exit
(gdb) run
[mozilla runs for a bit and exits]
(gdb) bt
[attach what you get here to this bug, "Create a New Attachment"]

you might need to rebuild parts of Mozilla without stripping the libs if Gentoo
is doing that in order to get a decent stacktrace.
Product: Browser → Seamonkey

Comment 7

13 years ago
Old version, no response > 1 y. Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 1.4 Branch
You need to log in before you can comment on or make changes to this bug.