Adding a web site to allowed popup site list crashes Mozilla [@ nsPermissionManager::Add ]

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: jlp.bugs, Assigned: mvl)

Tracking

({crash, regression})

Trunk
x86
All
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I'm using Mozilla 2003070908 on Windows XP with SP1. When I try to add some site
to a list of sites that are allowed to show popups Mozilla crashes. I sent 3
talkback reports: TB21772355E, TB21772352X, TB21772302H. I also noticed that
sites that are allowed to show popups are not listed in the Popup Manager.

Reproducable: allways

Steps to reproduce:
1. Open Mozilla
2. Go to Tools > Popup Manager > Manage popups
3. Enter some site. For example www.test.com
4. Click Add
5. Click OK

Actual result:
Mozilla crashes after clicking OK

Expected result:
Mozilla should add the site to the list and close the window.

Comment 1

16 years ago
wfm using build 2003070308 on Win2k, regression between 2003070308 and 2003070908.
Severity: blocker → critical
Keywords: stackwanted
Whiteboard: TB21772352X

Comment 2

16 years ago
Seeing those crash on a current based CVS trunk build - Linux.

So, it seems to be an OS->All problem.
(Reporter)

Updated

16 years ago
OS: Windows XP → All
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 127458 [details]
Stack for talkback 21772352

Updated

16 years ago
Keywords: stackwanted
Summary: Adding a web site to allowed popup site list crashes Mozilla → Adding a web site to allowed popup site list crashes Mozilla [@ nsPermissionManager::Add ]
Whiteboard: TB21772352X
(Assignee)

Comment 4

16 years ago
Created attachment 127468 [details] [diff] [review]
ptrcheck and update caller

Forgot to check aType for a correct pointer. The popup manager used the old
nnumber version, instead of the string. Forgot to update that file.
Fixed that, and checking for a pointer now.
Attachment #127468 - Flags: superreview+
(Assignee)

Comment 5

16 years ago
Comment on attachment 127468 [details] [diff] [review]
ptrcheck and update caller

<dwitte_away> mvl: r=dwitte for the NS_ENSURE_ARG and caller fix.

Marking as such.
Attachment #127468 - Flags: review+
(Assignee)

Comment 6

16 years ago
Comment on attachment 127468 [details] [diff] [review]
ptrcheck and update caller

Requesting approval for this fix for a quite visible crash. That patch itself
is low-risk, mainly a few checks for correct pointers.
Attachment #127468 - Flags: approval1.5a?

Comment 7

16 years ago
-> mvl.
Assignee: ben → mvl
Attachment #127468 - Flags: approval1.5a? → approval1.5a+

Comment 8

16 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
Crash Signature: [@ nsPermissionManager::Add ]
You need to log in before you can comment on or make changes to this bug.