Unable to bookmark page without title by dragging from locationbar to Bookmarks button

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Erik Huelsmann, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Go to any page without a title (the page at the referenced URL does not have a
<head> section) and drag the favicon to the Bookmarks button. If you release the
drag, mozilla beeps and refuses to bookmark the page.

Reproducible: Always

Steps to Reproduce:
1. Go to the mentioned URL
2. Drag favicon to Bookmarks button
3. Release drag over Bookmarks button

Actual Results:  
Mozilla beeps and does not bookmark.

Expected Results:  
Add the page to the bookmark list (probably displaying the url, since there is
no title)

Comment 1

15 years ago
->Bookmarks
Component: Browser-General → Bookmarks

Comment 2

15 years ago
->Bookmarks
Assignee: general → chanial
QA Contact: general → petersen

Comment 3

15 years ago
worksforme with linux trunk 20030708 and 1.4
(Reporter)

Comment 4

15 years ago
Then maybe the key is that I have already added 3 bookmarks to the button. It
will  not add any bookmarks anymore. I'm using 1.4.

Comment 5

15 years ago
Confirmed on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b)
Gecko/20030821 Mozilla Firebird/0.6.1+

As a sidenote, this only happens if the document you try to bookmark is an index
page which isn't shown in the URL (e.g. index.html, default.asp, ...), it is
located at the webserver's document root, and it has no title.

I can NOT reproduce this bug with the URL provided by the submitter. On the
other hand, the following document fails to get bookmarked when I drag the icon
from the URL Bar to either the Bookmarks Manager or the Bookmarks Toolbar:
 
http://www.citytron.com/ 

Bookmarking via the menu works as expected.

Comment 6

15 years ago
Bug Day: 1-13-2004
Tested With: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040113

This seems to be resolved on the version I tested with. Both with the example
page provided, as well as another test page. Have you tested with a recent version?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.