Closed Bug 21234 Opened 20 years ago Closed 20 years ago

[dogfood]Visit the different Meta charset page problem

Categories

(Core :: Internationalization, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: ftang)

References

()

Details

(Whiteboard: [PDT+] might have been fixed by 20315)

Japanese characters in this page are displayed as garbage.

Steps of reproduce
1. Open Navigator, by defult http://www.mozilla.org shows
2. Go to http://home.netscape.com/ja/
3. Click link "日本のディレクトリ(日本語)" to go to the above URL

Notice that the Japanese characters are displayed as garbage.

After you reload the page, the Japanese characters are displayed correctly.

http://www.mozilla.org   ---  no Meta charset.
http://home.netscape.com/ja  ---- Meta charset x-sjis
http://directory.netscape.com/World/Japanese/   ---- Meta charset EUC-JP

Tested 120808 Linux, Mac, and Win32 build.
Summary: Visit the different Meta charset page problem → [dogfood]Visit the different Meta charset page problem
Target Milestone: M12
Whiteboard: [PDT+]
Putting on PDT+ radar.
Assignee: ftang → cata
*** Bug 21349 has been marked as a duplicate of this bug. ***
*** Bug 21349 has been marked as a duplicate of this bug. ***
*** Bug 21401 has been marked as a duplicate of this bug. ***
Depends on: 21429
Check out bug 20315 - I posted a patch at the end that fixes that bug and may
also fix this bug?  When I went to this page with my patched build, garbage
characters were not displayed, but chinese fonts (I had set it to display Big 5
charset, so I imagine if one installed japanese fonts and selected those it
would work too?)
Checked in those fixes - this bug might be fixed too?
Whiteboard: [PDT+] → [PDT+] might have been fixed by 20315
Assignee: cata → ftang
I have check in my fix, this should be fixed.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed in Win 12-16-09-M12 bld.
Status: RESOLVED → VERIFIED
I verified this in 121608 Win32 under Win95J, Win98J, and Winnt 4.0J, and
121612 Linux and Mac build.
You need to log in before you can comment on or make changes to this bug.