If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FEATURE]New Account Defaults for "Copies & Folders"

VERIFIED FIXED in M15

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview: The "Copies and Folders" panels should have certain folders selected
by default when a new account is created.

1. Mail Accounts:
- When sending messages, automatically
Place a copy in: `"Sent" on <acct>` (i.e. Sent on qatest33)
- Keep message drafts in `Drafts on <acct>`
- Keep message stationery in `Stationery on <acct>`
- Keep junk mail in `Junk Mail on <acct>`

2. News Accounts:
- When sending messages, automatically
Place a copy in: `"Sent" on Local Mail`
- Keep message drafts in `"Drafts" on Local Mail`
- Keep message stationery in `"Stationery" on Local Mail`
- Keep junk mail in `"Junk Mail" on Local Mail`

Account Setup Spec:
http://gooey/client/5.0/specs/mail/accountSetup/accountSetup.html
(Reporter)

Updated

18 years ago
QA Contact: lchiang → nbaca
Summary: [FEATURE]New Account Defaults for "Copies & Folders" → [FEATURE]New Account Defaults for "Copies & Folders"
(Reporter)

Comment 1

18 years ago
Setting QA Contact to nbaca.

Comment 2

18 years ago
Are we really doing the Junk Mail thing in 5.0?

Updated

18 years ago
Blocks: 10791

Comment 3

18 years ago
I don't think so. cc: jennifer for clarification.
Status: NEW → ASSIGNED
Target Milestone: M14
good catch.

what about imap vs. pop?  one could argue that for imap, the sent pref should
default to local mail.

and for news, imagine this scenario:
in 4.x, user has 1 news and 1 pop server. the fcc prefs point to the one and
only sent folder "under" the pop server.
user migrates to 5.x, so they have 1 news and one pop (no local mail, only imap
users get that.) the fcc prefs point to the sent folder "under" the pop server
user creates a new news server.
the sent pref defaults to (if we follow your logic) local mail, which doesn't
exist.  do we create it?
or do we default the fcc pref to the sent folder "under" the pop server.

does that make sense?

a lot of these problems are harder to figure out, then in 4.x, because in 4.x we
had one identity.

oh well, we'll solve it.  not dogfood, marking m14.

Comment 5

18 years ago
No Junk Mail for 5.0.

Very good points. We need to come up with some default behaviors.  Ninoschka is
putting together a list of potential cases and we will discuss at a future Mail
Issues Meeting.
if there is no junk mail in 5.0, I'll log a bug to remove the ui elements for
it.

doing that now.

Updated

18 years ago
Target Milestone: M14 → M15
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
marking this fixed.

we do this now, except in the imap case.

in the imap case, we go to local folders, and not the folders on the imap
server.

Comment 8

18 years ago
1/13/00 Mail Issues Meeting will cover this topic.  The current behaviors are
discussed in the UE spec at:
http://gooey/client/5.0/specs/mail/messenger/messenger.html#MailFolders

This section will be updated following the meeting to reflect team decisions.

Comment 9

18 years ago
*** Bug 17501 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Using commercial builds 2000011109m13 on win98, 2000011110m13 on linux and
mozilla Mac build 2000011109m13 this is partially fixed.

A new POP account on  Win and Mac will default to the Sent folder
A new POP account on linux no default

A new IMAP account on all three no default Sent folder set.  Note: the IMAP
account I used, already had a Sent folder created on the server previously.
So IMAP is not working as stated in previous statement by sspitzer dated
2000-0111.  Also, when I manually check the box and select the Local Sent folder
a copy does not go there, this would be regression.

Will test again with 01/12 build to see if fix went in after the 01/11 date

Comment 11

18 years ago
Update: I just tested with todays windows build 2000011211m13 and adding a New
IMAP account does not set the Local Sent folder as default.
Note: There is a workaround, if you click on the Copies and Folders under Local
Folders, it will set that default and also set the IMAP account Copies and
Folders to what the Local Folder is set to.

Reopening because this is still not default, if user never uses the workaround a
default Sent folder is not entered for the IMAP account.
Status: RESOLVED → REOPENED
Status: REOPENED → ASSIGNED
yikes.

I see it on linux too.  new profile, add imap server, the defaults are not set
for the imap server, but they are for the local server.

the work around you describe scares me, and sounds like a bad bug.

based on what I see getting dumped to the console, it looks like
I am looking on the wrong server for the default folders.
(instead of looking on "local folders" I'm looking on the imap server.)

should be easy to fix.

thanks for catching this, esther.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
ok, I found the problem.

after all my yapping, I goofed and made it so for a new imap server, the copies
 and folders prefs defaults to the imap server, and not local folders.

Index: nsImapService.cpp
===================================================================
RCS file: /cvsroot/mozilla/mailnews/imap/src/nsImapService.cpp,v
retrieving revision 1.95
diff -r1.95 nsImapService.cpp
2413c2413
<       *aDefaultCopiesAndFoldersPrefsToServer = PR_TRUE;
---
>       *aDefaultCopiesAndFoldersPrefsToServer = PR_FALSE;

I still want to look at the workaround that esther describes, and that is really
a bug.

marking this fixed, and I'll look into the other thing now.

Comment 14

18 years ago
Seth, there is another part of this that's not working-Linux POP default is not
getting set (win & Mac are).  I didn't have a chance to check the Linux/POP
problem with today's build, will the fix you just did fix that too if it's still
a problem?
pop on today's linux build (the one I built) works for me.

esther is going to try hers again.

Comment 16

18 years ago
Pop on today's build works for me too!   Will wait for next build to test the
outstanding IMAP issue.
*** Bug 23457 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

18 years ago
Build 2000-03-09-13M15: NT4, Linux, Mac. 
Working in the following manner: 
- POP account points to POP/Sent folder, Draft and Stationery. 
- IMAP account points to Local Folders/Sent folder, Draft and Stationery.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.