[Dogfood]Crash clicking in text fields

VERIFIED FIXED

Status

()

Core
XUL
P2
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Simon Fraser, Assigned: saari (gone))

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] 12/9)

(Reporter)

Description

18 years ago
I'm seeing a crash when clicking in previously unfocussed text fields, e.g. the
URL bar, and the username field on the bugzilla login page. Stack follows:

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  1F4A88EC
  0B03C280    PPC  1F4A3034  main+001F8
  0B03C1D0    PPC  1F4A1814  main1(int, char**)+00754
  0B03C0E0    PPC  1DB8A480  nsAppShellService::Run()+000BC
  0B03C090    PPC  1DB257E8  nsAppShell::Run()+00050
  0B03C010    PPC  1DB260E8  nsMacMessagePump::DoMessagePump()+00044
  0B03BFC0    PPC  1DB265C0  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00138
  0B03BF60    PPC  1DB26A3C  nsMacMessagePump::DoMouseDown(EventRecord&)+000C0
  0B03BE70    PPC  1DB27574
nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, GrafPort
*)+0004C
  0B03BE20    PPC  1DB209F4  nsMacMessageSink::DispatchOSEvent(EventRecord&,
GrafPort*)+00048
  0B03BDE0    PPC  1DB192AC  nsMacWindow::HandleOSEvent(EventRecord&)+0004C
  0B03BD80    PPC  1DB1A1CC  nsMacEventHandler::HandleOSEvent(EventRecord&)+000B0
  0B03BD30    PPC  1DB1BB78  nsMacEventHandler::HandleMouseDownEvent(EventRecord&
)+002C8
  0B03BC40    PPC  1DAFF7C8  nsWindow::DispatchMouseEvent(nsMouseEvent&)+00060
  0B03BBE0    PPC  1DAFF664  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
  0B03BBA0    PPC  1DAFF570  nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&
)+000A8
  0B03BB50    PPC  1C97A37C  HandleEvent(nsGUIEvent*)+7A37C
  0B03BB00    PPC  1C97675C  nsViewManager::DispatchEvent(nsGUIEvent*,
nsEventStatus*)+7675C
  0B03B920    PPC  1C97C3E8  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus*, i
nt&)+7C3E8
  0B03B8A0    PPC  1C97C3E8  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus*, i
nt&)+7C3E8
  0B03B820    PPC  1C97C478  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus*, i
nt&)+7C478
  0B03B7A0    PPC  1BB20BB4  PresShell::HandleEvent(nsIView*, nsGUIEvent*,
nsEventStatus*)+20
BB4
  0B03B720    PPC  1BBDCCE4  nsEventStateManager::PostHandleEvent(nsIPresContext*
, nsGUIEvent
*, nsIFrame*, nsEventStatus*, nsIView*)+DCCE4
  0B03B570    PPC  1BBDF738  nsEventStateManager::ChangeFocus(nsIContent*,
nsIFrame*, int)+DF
738
  0B03B4F0    PPC  1BC6AA2C  nsHTMLInputElement::SetFocus(nsIPresContext*)+6AA2C
  0B03B400    PPC  1BBE0CA0  nsEventStateManager::SetContentState(nsIContent*,
int)+E0CA0

Another similar crash had a stack the looked like:

nsEventStateManager::ChangeFocus
nsHTMLInputElement::SetFocus
nsEventStateManager::SetContentState
nsEventStateManager::SendFocusBlur
nsHTMLInputElement::HandleDOMEvent
nsGenericElement::HandleDOMEvent

in nsGenericElement::HandleDOMEvent(), it looks like mParent is garbage.
(Reporter)

Updated

18 years ago
Priority: P3 → P2
Summary: Crash clicking in text fields → [Dogfood]Crash clicking in text fields
(Reporter)

Comment 1

18 years ago
Dogfood. Hinders my ability to login to bugzilla, and use forms.
(Reporter)

Comment 2

18 years ago
Steps to reproduce (build of about 11am today):
1. Make a new profile, or toss your cookies file, so you are forced to log into
bugzilla
2. Navigate to the enter bug page, click on the browser component. Now you get
sent to the login page. Click on the username field. Crash!
(Reporter)

Comment 3

18 years ago
I also see this crash when clicking on scroll bars (GFX variety)

Updated

18 years ago
Whiteboard: [PDT+]

Comment 4

18 years ago
Putting on PDT+ radar.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 12/9
(Assignee)

Comment 5

18 years ago
This should already be fixed, but I'm pulling to make sure...



This happened on Windows too and we fixed it yesterday
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
Yeah, I just verified this is fixed.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
good news is that I can't see this in any of the 19991209 build (Mac and Win32)
the bad news is I couldn't repro it in any of the 12/07-12/08 builds. Maybe this
was broken, found, and fixed inbetween one optimized build cycle? I'm gonna
mark it VERIFIED....
You need to log in before you can comment on or make changes to this bug.