Closing bookmarks window while a Flash site is open causes crash - Trunk [@ CancelImageRequest]

RESOLVED DUPLICATE of bug 256297

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 256297
15 years ago
13 years ago

People

(Reporter: John Holmstadt, Assigned: Pierre Chanial)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

When you open a Flash site, then go into the bookmark manager, then close the
bookmark manager, Mozilla crashes.

Reproducible: Always

Steps to Reproduce:
1.Open any Flash site (ie, Strongbad Email)
2.Go to Bookmarks menu, Manage Bookmarks.
3.Close the Bookmark Manager window.

Actual Results:  
Mozilla crashed.

Expected Results:  
Not crash.

Mozilla 1.4 with Xft/AA support.
Version information from about:plugins is "Shockwave Flash 6.0 r79"
User agent is "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701"
Running mozilla-1.4-11.i386.rpm from
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4/contributed/Red_Hat_8x_RPMS/gtk2/RPMS/i386/
The results of "uname -a" are "Linux plutus.office.athenet.net 2.4.20-18.8smp #1
SMP Thu May 29 07:20:32 EDT 2003 i686 i686 i386 GNU/Linux"
Running on Redhat Linux 8.0
Product: Browser → Seamonkey

Comment 1

13 years ago
I can confirm this on Windows, Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US;
rv:1.8b) Gecko/20050117
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
Talkback IDs: TB3122493M, TB3121124W, TB3121111K, TB3121094G
CancelImageRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 119]
hashEnumerate 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 131]
nsHashtable::Enumerate 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 319]
nsTreeBodyFrame::~nsTreeBodyFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 174]
nsTreeBodyFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 366]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp,
line 129]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1117]
nsPositionedInlineFrame::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsInlineFrame.cpp,
line 1107]
DocumentViewerImpl::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 1203]
nsDocShell::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 3309]
nsXULWindow::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsXULWindow.cpp,
line 489]
nsWebShellWindow::Destroy 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp,
line 1584]
nsWebShellWindow::Close 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp,
line 331]
nsWindow::DispatchEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1103]
nsWindow::DispatchStandardEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1143]
nsWindow::ProcessMessage 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 3833]
nsWindow::WindowProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1389]
USER32.dll + 0x16080 (0x77396080)
USER32.dll + 0x1614d (0x7739614d)
USER32.dll + 0x162ca (0x773962ca)
USER32.dll + 0x1648c (0x7739648c)
ntdll.dll + 0x3635e (0x7c83635e)
USER32.dll + 0x16380 (0x77396380)
USER32.dll + 0x163ea (0x773963ea)
nsWindow::DefaultWindowProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1415]
USER32.dll + 0x16080 (0x77396080)
USER32.dll + 0x1614d (0x7739614d)
USER32.dll + 0x16b42 (0x77396b42)
USER32.dll + 0x16b68 (0x77396b68)
nsWindow::WindowProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1396]
USER32.dll + 0x16080 (0x77396080)
USER32.dll + 0x1614d (0x7739614d)
USER32.dll + 0x162ca (0x773962ca)
USER32.dll + 0x1648c (0x7739648c)
ntdll.dll + 0x3635e (0x7c83635e)
USER32.dll + 0x16380 (0x77396380)
USER32.dll + 0x163ea (0x773963ea)
nsWindow::DefaultWindowProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1415]
USER32.dll + 0x16080 (0x77396080)
USER32.dll + 0x1614d (0x7739614d)
USER32.dll + 0x16b42 (0x77396b42)
USER32.dll + 0x16b68 (0x77396b68)
nsWindow::WindowProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1396]
USER32.dll + 0x16080 (0x77396080)
USER32.dll + 0x1614d (0x7739614d)
USER32.dll + 0x1702d (0x7739702d)
USER32.dll + 0x17070 (0x77397070)
nsAppShell::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp,
line 159]
nsAppStartup::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/components/startup/src/nsAppStartup.cpp,
line 208]
main 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1811]
WinMain 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1839]
kernel32.dll + 0x11331 (0x77e51331)
Vedran, I think what you're experiencing is bug 256297. This bug was probably
originally about something else, though.
Summary: Closing bookmarks window while a Flash site is open causes crash → Closing bookmarks window while a Flash site is open causes crash [@ CancelImageRequest]

Comment 5

13 years ago
Yeah, that's probably the right bug... search came out with this one, so I
thought this was the issue I experienced :) Thanks for the info, Martijn.

Comment 6

13 years ago
Martin, I can reproduce this bug too, and I think it's pretty similar issue to
that one. Do you think it would be a good idea to duplicate it to bug 256297?

Comment 7

13 years ago
*** Bug 256297 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
I marked that other bug a dup of this one since we have more recent data here
and the other bug had not been touched for a while.  This appears to be at
topcrasher with recent MozillaTrunk builds, so adding topcrash info for tracking.

Are we sure that Flash content has anything to do with this?  I'm wondering if
this is a Flash crash, bookmarks crash or a combination of both.

Here is a link to a Talkback query for all "CancelImageRequest" crashes:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=cancelimagerequest&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid
Keywords: crash, topcrash
OS: Linux → All
Summary: Closing bookmarks window while a Flash site is open causes crash [@ CancelImageRequest] → Closing bookmarks window while a Flash site is open causes crash - Trunk [@ CancelImageRequest]

Comment 9

13 years ago
I don't think this has anything to do with flash.  I can be on NO site and have
the problem.  In fact I have the problem 100% of the time.

I commented at
https://bugzilla.mozilla.org/show_bug.cgi?id=256297#c1
with my experience.

However, (see the link), my problem started when I changed from GNOME to KDE.

Jay

Comment 10

13 years ago
Yay, you duped bug 256297 to this one. First of allsorry for filing the dupe,
this bug report had no Talkbacks posted and was lacking the @CancelImageRequest
in the summary. Moreover, if you look at bug 256297, it says that the crash also
occurs on "Open Navigator. Press CTRL-B, push the red X in the top right corner
to close
the bookmark manager. Moz crashes." 

Nothing flash related [i open with "about:blank"].

But even though bug 256297 was filed later, it had more CC's and as stated in
comment 4 and comment 6 is on a more recent build. Most of all, THAT bug already
had a partial patch...

Comment 11

13 years ago
reversing duping for the reasons given in comment 10.

*** This bug has been marked as a duplicate of 256297 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ CancelImageRequest]
You need to log in before you can comment on or make changes to this bug.