courrierinternational.com - Page continuously reloads and never displays completely

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Marc-André Descôteaux, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030711 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030711 Mozilla Firebird/0.6

Every "Destination" page on this site does this in Mozilla Firebird, as it did
in Mozilla. Whenever I try to access one, the page does not finish displaying
and reloads constantly.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.courrierinternational.com/voyage/00-voyage.htm
2. Choose any destination in the "Destinations" drop-down menu.
3. See the bug in action.

Actual Results:  
Page reloads, and reloads, and reloads.

Expected Results:  
Mozilla should load the page once and display it.

Comment 1

15 years ago
If it does it in Mozilla as well, it's a Browser bug.
->Browser
Assignee: blaker → general
Component: General → Browser-General
Product: Firebird → Browser
QA Contact: asa → general
Version: unspecified → Trunk
Do you allow cookies from this site?
(Reporter)

Comment 3

15 years ago
Boris --> I have no restrictions whatsoever on cookies, nor on images or
Javascript. I tried with pop-up windows allowed, to no avail.

Comment 4

15 years ago
Confirming with Mozilla 1.6b and a different URL, in my case
http://hfnetchk.shavlik.com/support/hfpro4help/hfn.htm

Both my, and the example URL use Javascript rather a lot, which is where I
suspect the problem is.
Status: UNCONFIRMED → NEW
Ever confirmed: true
David, any chance of a minimal testcase?  In the future, please do NOT confirm
bugs like this without a minimal testcase....

Comment 6

15 years ago
I should have thought of that. Testcase coming....

Comment 7

15 years ago
Created attachment 137520 [details]
Minimal testcase

This is the root of the problem. The IF statement tests conditions which are
set in the 3 external JavaScript files. In all 3 cases the variable is set to
TRUE at the very end of the included JS file.

Comment 8

15 years ago
Just been doing some testing. I changed the testcase so that the 3 external
javascript files were no longer external (quick copy & paste).

When I do that, the javascript works fine and gbWhVer, gbWhUtil & gbWhMsg are
all true. When left as external files, gbWhVer is true, and gbWhUtil & gbWhMsg
are both undefined.

Now, I'm not a Javascript guru, but shouldn't it matter if the Javascript code
is in the html file, or "included" from an external file?
Hmm.. When I load http://hfnetchk.shavlik.com/support/hfpro4help/hfn.htm with
mozilla trunk nightly 2003-12-14-08, all three vars are defined (and "true") and
there is no looping.  There is also no reloading in the same build on
http://www.courrierinternational.com/voyage/Articles/AME/cl01-240702.htm

Comment 10

15 years ago
I've just checked with a local build from this morning NZDT, and I get the same
problem. What OS are you using with the 14/12 trunk build?
Linux. Sorry, thought I said that.  :(

Comment 12

15 years ago
I've just tested Mozilla 1.6b on Fedora Core 1 Linux, and hit the reloading problem.

I'm now building a more current version to see what happens.
This could also depend on profile settings, I suppose.  I was _not_ testing with
a vanilla profile....

Comment 14

15 years ago
Just got the same behaviour from a fresh build of Mozilla on Linux. Changing OS
to ALL.
OS: Windows XP → All
David, can you test with a vanilla profile?  I'll try to get my hands on a
Mozilla build again and do the same.

Comment 16

15 years ago
OK, you were right in comment #13, this seems to be a profile issue, at least
for my testcase.

I created a new profile, using Mozilla 1.6b, and the page loaded (although it
seemed to be doing a lot of repainting as it loaded different parts of the page.
Once the page is in cache, it loads no problem. I even tried changing from the
default "classic" theme to the "modern" theme, but that didn't break it.

The courrierinternational site still reloads, and gives me lots of popups.

Comment 17

15 years ago
I just tried Firebird v0.7 to see what it does. Got the same results as with
Mozilla and a new profile.

I'm going to cutdown the other example URL to find the core problem that it has.

Comment 18

15 years ago
Hmmm, the courrierinternational site contains interesting HTML.  Nested BODY
statements for example "<BODY>blah blah<BODY>blah blah</BODY>blah blah</BODY>".

I'm going to keep trying to reduce it to see if it is another example, but I
think it has other problems.

Comment 19

15 years ago
Created attachment 137686 [details]
courrierinternational min testcase

OK, got the courrierinternational site down to the essential problem (ignoring
the invalid HTML).

What is happening AFAIK is that a Javscript function called "taille()" is
called, which seems to drop down and rerun itself....I assume if I left it
running long enough it would use up all memory and crash my PC.
Well, that code basically does:

if (browser is IE) {
  // do something
} else if (browser is NS4) {
  // do something
} else {
  // set location to the current page location, causing page to reload and this
  // script to run again
}

It wouldn't use up all your memory, because that last part is async.

In any case, this is evang -- any browser that implements neither
document.layers nor document.all would loop on that site.
Assignee: general → english-us
Component: Browser-General → English US
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Note, though, that what I said only applies to browsers whose appVersion
includes the string "Win" or the string "Mac" (which Mozilla on Linux typically
does not).

Updated

14 years ago
Summary: Page continuously reloads and never displays completely → courrierinternational.com - Page continuously reloads and never displays completely
(Reporter)

Comment 22

14 years ago
The "Courrier international" website has been redone, and the reload no longer
occurs. Should this bug be closed, or at least renamed?

Comment 23

14 years ago
It can be marked FIXED.
.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.