Closed Bug 212489 Opened 19 years ago Closed 13 years ago

Clicking quickly on two different files in filepicker counts as double-click

Categories

(Core :: XUL, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bryner, Unassigned)

Details

Steps to reproduce:

1. Bring up the Open File dialog.
2. Click once on a file, then quickly click on a different file

Result: the second file is chosen and the dialog is dismissed, as if you'd
double-clicked it.
Expected result:  the same as if you'd clicked on the second file slowly -
select the file but do not dismiss the dialog.
Assignee: bryner → jag
QA Contact: jrgmorrison → xptoolkit.widgets
Assignee: jag → nobody
needs linux test - is this just linux behavior, or mozilla?
see also Bug 91337 and bug 91338
Harald, is this also gone, like bug 260691?
I cannot reproduce it, either with 3.0.11 and with a recent nightly build. When that bug was opened, was filepicker still in xul, or was it already gtk filepicker ? If that bug was opened against xul filepicker, maybe it has disappeared when changing filepicker.
very likely. Thanks Arno.
=> WFM per comment 3
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.