find as you type doesn't work on freshly loaded page

NEW
Unassigned

Status

SeaMonkey
Find In Page
15 years ago
4 years ago

People

(Reporter: Andreas Kloeckner, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Linux
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030607 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030607 Mozilla Firebird/0.6

Type-ahead finding the word "gimp" on the page referenced by the URL stops after
saying 'link not found "gim"'. The malfunciton occurs only when the page is
freshly loaded, after the first search times out, the appropriate link is found ok.

Reproducible: Sometimes

Steps to Reproduce:

Comment 1

15 years ago
worksforme with linux trunk 20030712
Summary: http://cvs.gimp.org/bonsai/rview.cgi?cvsroot=/cvs/gnome → find as you type doesn't work on freshly loaded page

Comment 2

14 years ago
Created attachment 130443 [details]
A request for information on how to reproduce the bug.

I have been trying to reproduce the bug using 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030826 Mozilla
Firebird/0.6.1+ and was not able to. The steps to reproduce the bug is not
explicit.
(Reporter)

Comment 3

14 years ago
1. load page by clicking on "URL" above.
2. hit "g"
3. hit "i"
4. hit "m"
5. notice how it says "link not found" in the status bar, also notice that
"gimp" is clearly mentioned on the page.

Comment 4

14 years ago
Created attachment 130572 [details]
Test repeated three refreshed times

I reloaded the page three times and each time typing gimp and pressing the
return key produced the gimp directory using;
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030826 Mozilla
Firebird/0.6.1+
Attachment #130443 - Attachment is obsolete: true

Comment 5

13 years ago
I've found that while going through a slideshow on Yahoo! News, that in the
slide show there are next links.  So, upon each page load, and after the status
bar says "Done", I start typing "xt" since xt ususally doesn't show up in any
other links on that page.  

If I do so within 1-2 seconds of the page being loaded, i.e. see Done in the
status bar and immediately start typing, the text is not found.  Also, if you
start typing before the page is loaded (or at least when find as you type allows
you to start) the text isn't found.  Yet if you wait .5-2 seconds after the page
loads, it works.

I tried this on several sites.  Same results.  Running Windows XP, Firefox
1.0PR.  Could extensions cause this?  Extensions I'm running:
DOM Inspector, All-in-One Guestures, ieview, Web Developer

I've attached the screenshot.

Comment 6

13 years ago
Created attachment 159749 [details]
A screenshot of when Firefox does not Find as you Type, though it should.

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
win XP
fresh install, no extensions. Same issue

Find as you type fails while the page is loading. The key buffer is still
filling while you type, so you have to clear it when the pages is fully loaded

Comment 8

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1
(Debian package 1.0.1-2)

I have the same problem on two different machines. Find As You Type isn't able
to find links until a few seconds after the page finishes loading. Note that I
have accessibility.typeaheadfind.linksonly set to true. ctrl-g will then find
the text after the initial "doesn't work pause" is over.

I use keyboard navigation via FAYT on http://z.iwethey.org/forums, and I have to
pause after each page load before it actually works. Or, I can type my phrase in
and then hit ctrl-g a few times until it works.

This problem is only apparent when I start typing for the link during the page
load or just after the page load. If I pause for a few seconds, it will work.

As an example, load http://z.iwethey.org/forums/render/board/show?boardid=1 and
type in "y b" (the letter y, a space, the letter b) right after the page loads.
You can refresh and try again if it works the first time. If you have linksonly
turned on, this should highlight the link at the top of the page "IWETHEY
Board", but usually I just get "not found" and I have to try again.

Comment 9

13 years ago
Note that I didn't have this problem in preceding versions of Firefox (0.8,
IIRC), only after I upgraded to 1.0.

Comment 10

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414
Firefox/1.0.3

I can reproduce this way:

1. Open new window
2. Open this bugzilla page in it
3. Middle-click on the second link in comment #8
4. Click on that tab and try using find-as-you-type.  This fails.
5. Now close the tab and copy the link
6. Create a new tab (Ctrl-T)
7. Paste the link into the address bar
8. Try using find-as-you-type.  Works fine

Could this be an issue of tab focus?

Incidentaly, though find doesn't work, highlight still nicely highlights the
appropriate bits on the page

Comment 11

13 years ago
Starting FireFox in Safe Mode for me seems to fix this problem, so it may be
related to one of the many extensions installed on my system.

Is this a dupe of/duped by 270546?

Comment 12

12 years ago
Noticed an interesting effect that this problem seemed to occur more on a faster
connection. Testing with this, observed a more accurate way to reproduce this bug.

Open a link in the background under a new tab.  Let the page fully load. Now go
to the tab and Find as you type fails.

Do the same, but go there before the page has fully loaded.  It now works fine.

HOWEVER, following up my safe-mode comment, I tried uninstalling all my
extensions and re-installing them one by one to see which was the culprit.  The
strange thing was, with them all re-installed, the problem had gone on my system.

Comment 13

12 years ago
Here is a page I made to help reproduce this bug which I hear is fixed in the
newest beta but have not verified:

http://somethinginteresting.org/firefox_bug_test.html

Updated

12 years ago
Assignee: aaronleventhal → nobody
Keywords: helpwanted
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey

Comment 14

4 years ago
Can't reproduce even with the 'links only' option.
SeaMonkey/2.17.1
You need to log in before you can comment on or make changes to this bug.