Distributed Proofreaders spellchecker no longer works since Moz v1.4

RESOLVED DUPLICATE of bug 225811

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 225811
15 years ago
15 years ago

People

(Reporter: Brendan McEnaney, Assigned: roc)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030705
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030705

The spellchecker function of the proofreading/editing page at Distributed
Proofreaders (http://www.pgdp.net/c/default.php)that worked fine with previous
versions of Mozilla no longer works with v1.4. It worked fine with v1.31 and
earlier. Sorry, but this only can be checked out by someone with an account at
pgdp who is logged in so as to open a page to proofread. 

Reproducible: Always

Steps to Reproduce:
1. Log in at Distributed Proofreaders.
2. Select a page from a project to proofread.
3. Click the button to spellcheck the page.

Actual Results:  
A blank page (frame) is displayed. Checking the source for the frame shows the
source for what should be displayed (An example of this source can be viewed here:
http://www.speakeasy.org/~mcenaney/DP-spellcheck-Frame_source-example).

Expected Results:  
A two frame window displaying the OCR image of the original page in the upper
frame and a spellcheck editing function in the lower frame should have been 
displayed. This expected result can be seen by repeating these steps using
Mozilla v1.31 or earlier.

I've reported this on the DP forum in the General section under the header
"Spellchecking in Moz hosed?". There was a couple of confirming followups and a
suggestion to submit a bug report here; thus here I am. I'm uncertain that this
IS actually a Mozilla bug as opposed to a DP site bug. 

Note that the problem does NOT occur using:
- versions of Mozilla prior to v1.4
- MSIE (running under the Crossover Office version of Wine)
- Galeon v1.2.7

The problem DOES occur using:
- Mozilla 1.4*
- Firebird 1.6**
- Opera v7.11 (which makes me think this may be a wasted bug report)

*Mozilla was compiled from source under Redhat 9. 
.mozconfig contained:
ac_add_options --enable-xft
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-crypto
ac_add_options --enable-calendar

**Firebird was compiled the day 1.6 was released from source thusly:
wget http://64.12.168.21/pub/mozilla/nightly/latest/mozilla-source.tar.bz2
tar -xjf mozilla-source.tar.bz2
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot checkout
mozilla/browser mozilla/toolkit

.mozconfig contained:
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --with-pthreads
ac_add_options --disable-mailnews
ac_add_options --disable-ldap
ac_add_options --enable-xft
ac_add_options --disable-jsd
ac_add_options --enable-crypto
ac_add_options --disable-accessibility
ac_add_options --disable-composer
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O3 -march=pentium3 -mfpmath=sse,387"
ac_add_options --enable-strip

I'm not sure that this is specific to Linux as I don't have another platform to
test on. The others who chirped in on the DP forum were running Linux as well.

Sorry if this belongs in a javascript section but if it does, I couldn't figure
out which one.

Comment 1

15 years ago
Confirming and setting OS->All (I see this on 1.4final, W2k).

-> Layout:View Rendering. I think this is essentially a duplicate of bug 170011,
but I'll let someone with better CSS-fu confirm that.

Attaching a (much!) simplified testcase.
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: View Rendering
Ever confirmed: true
OS: Linux → All

Comment 2

15 years ago
Created attachment 128412 [details]
Simplified testcase

In this testcase, the BODY has overflow:auto, which means it should provide
scrollbars to view it's contained content. However, the IMG within the BODY is
absolutely positioned, so the BODY is not the containing block for the IMG.

The result (which you can verify with the DOM inspector) is that the BODY is
shrunk to essentially nothing, the IMG is placed correctly, but there's no way
to scroll to it.

See also bug 170011 comment 7.

Comment 3

15 years ago
regression, since this works in 1.3.
Keywords: regression
Hardware: PC → All

Comment 4

15 years ago
re: comment 2, "there's no way to scroll to it"

I should really read comments before posting them.  There's no problem scrolling
around the view; it's just that the IMG appears to be clipped to the body.

Comment 5

15 years ago
Created attachment 128413 [details]
Better Testcase

Alternatively, could this be a duplicate of bug 131475 or bug 79315.

Comment 6

15 years ago
Still a problem with:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827

Comment 7

15 years ago
-> default contatcts (was assigned to general@browser.bugs)
Assignee: general → roc
QA Contact: general → ian

Comment 8

15 years ago
Still a problem in 1.5 and Firebird 0.7 on Windows 2000. The very small page
that I have included below displays nothing.

And I'd agree that it looks very much like bug 170011.

<html>
  <body style="overflow:auto;">
    <div style="position:absolute;">aaa</div>
  </body>
</html>

Comment 9

15 years ago
I'm now fairly convinced that this is caused by bug 225811 (which has a fix).
Worksforme in a current build.... Marking duplicate based on that.

*** This bug has been marked as a duplicate of 225811 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.