mouse wheel scrolling doesn't work on some other sites after window has been minimized

VERIFIED FIXED in mozilla1.5beta

Status

()

defect
VERIFIED FIXED
16 years ago
a month ago

People

(Reporter: BWallmeier, Assigned: bryner)

Tracking

Trunk
mozilla1.5beta
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030712 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030712 Mozilla Firebird/0.6

Sometimes when I open a website my mousewheel has a function, and sometimes not.
Its different where the bug came and where not.

My mous is the Microsoft Optical Wheelmouse with the Microsoft Drivers.
I have Windows XP SP1

Reproducible: Sometimes

Steps to Reproduce:
1.Open a website
2.Scroll with the mousewheel

Actual Results:  
Sometimes the site don't scroll done. Sometimes it scroll down.

Expected Results:  
Everytime it should work, that I can use my mouse wheel to scroll down.
Björn, your bug report is anything but helpful. Without a clear and reproducible
testcase, nothing can be done to fix this.

Do you have any special sites, where scrolling doesn't work at all? Are you
sure, that every time you tried to scroll the current window had the focus and
not another window, a text box or a combo box?
(Reporter)

Comment 2

16 years ago
I know thats a problem. 
I can't say a specific site where the problem come. 
I have the feeling, that the bug isn't it in the lastet nightly built. In the
moment I can always use the mousewheel.

But I think thats the problem came, when the Firebird lost the window focus.
When I switch the programm with Alt+Tab (I hope that you know that keys on the
keyboard) to a other program and later back.
(Reporter)

Comment 3

16 years ago
I have forgotten the User-Agent for the lastest built. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714 Mozilla
Firebird/0.6

Björn
(Reporter)

Comment 4

16 years ago
Now the problem was there back. 
I have two tabs open, and my email program make that sound when I get emails.
I minimize Firebird and then I open it(its minimize in the systray). It's
Gemail(www.gemail.de). After reading the emails I use Alt+Tab to maximize
Firebird back. And then in the "active" tab I can't scroll with the mousewheel.
The homepage is not the problem. Firebird has the focus. 

It's a problem from firebird or it's my email program? I don't know. Sorry. :(

Comment 5

16 years ago
i can confirm this bug with Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT;
rv:1.5a) Gecko/20030710
I am using a Logitech Mouse and I am using Windows XP SP1.
Steps to reproduce are:
1.open mozilla (or firebird nightly, like björn w. did)
2.open whatever webpage.
3. minimize mozilla/firebird
4. restore the window

Actual result:the page can`t be scolles using the mousewheel
This behavior disapears if you go to another page!

Expected Results: Scrooling should always work...
OK, I can confirm it now, but only on specific pages. If I try to load this bug,
minimize and then restore the window, scrolling with the mouse wheel works just
fine. But if I load up my GMX inbox, minimize the window and then restore it, it
doesn't work.

Jan, Björn, can you post a list of pages where scrolling always doesn't work? We
need to isolate a simple testcase here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

16 years ago
I have found a site:
www.free-av.de (in the forum)

And I have found something out. 
I minimize firebird then I maximize it I can't scroll. But after I maximized it,
I clicked in the URLBar to copy the Adress, I can scroll... 

Björn
Yeah, I see too on this site.
Summary: mouse wheel has sometimes a function and sometimes not → mouse wheel doesn't work on free-av.de bulletin board and soem other sites.
(Reporter)

Comment 9

16 years ago
When you can't scroll you must click in the URLBar to mark the URL, then you
click back somewhere on the website and now you can scroll. (No reload)

Björn
Summary: mouse wheel doesn't work on free-av.de bulletin board and soem other sites. → mouse wheel doesn't work on free-av.de bulletin board and some other sites
*** Bug 213340 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Info I found out last night when testing it more:

Using "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6" (Windows 2000 Pro) this problem has never occured, however
it occurs frequently using the same build for Windows NT 5.1 (Windows XP Pro).
The problem occurs on any webpage. It has occured on mozilla.org's front page,
and even in bugzilla. It also seems to only occur when changing focus to an
internet comms utility like Gaim, Outlook Express, Outlook, etc. and then
changing back to MozillaFirebird; however it does not occur EVERY time you
switch to those programs. It is confusing, there must be a solid chain of events
that leads to this loss of function.

Comment 12

16 years ago
Bug 214310 is possibly a dupe and has an additional testcase.
Someone with permissions please mark it so.
*** Bug 214472 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
could someone with more mozilla permissions change the summary to include
"scroll" and "minimize"?  thanks.  couple of test cases coming in from bug 214472.
Summary: mouse wheel doesn't work on free-av.de bulletin board and some other sites → mouse wheel scrolling doesn't work on some other sites after window has been minimized

Comment 15

16 years ago
*** Bug 214310 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: --- → Firebird0.7

Comment 16

16 years ago
-> bryner
Assignee: blake → bryner
Steps to reproduce reliably on WinXP:

0. Start the browser.
1. Open this bug report ( http://bugzilla.mozilla.org/show_bug.cgi?id=212556 )
2. click the "URL:" link at the top of the page
3. minimize the window
4. restore the window
5. try to scroll

the important point seems to be that you click a link to navigate to the new
page. loading the free-av.de site as the first page after starting the browser
doesn't seem to be able to reproduce it, nor does opening it in a new tab. 
(Reporter)

Comment 18

16 years ago
Hello,
when the scrollfunction is away and you click in the urlbar and then on one
point on the website the scrollfunction is back.
I don't understand it, but it works.

Björn
(Assignee)

Comment 19

16 years ago
Posted patch patchSplinter Review
Ok, I think the problem here is that the focus controller is continuing to hold
onto an element in the old document in its mPreviousElement.  On win32, we use
the previous element to restore focus after a window is unminimized.  So we end
up trying to focus an element with no frame, which doesn't work very well.

This patch ensures that the previous element is cleared out on destruction of
the document viewer, if the previous element is in that document.
(Assignee)

Updated

16 years ago
Attachment #129497 - Flags: review?(ere)
Comment on attachment 129497 [details] [diff] [review]
patch

Looks good to me. r=ere@atp.fi
Attachment #129497 - Flags: review?(ere) → review+
(Assignee)

Updated

16 years ago
Attachment #129497 - Flags: superreview?(jst)

Comment 21

16 years ago
*** Bug 214636 has been marked as a duplicate of this bug. ***
Comment on attachment 129497 [details] [diff] [review]
patch

sr=jst
Attachment #129497 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 23

16 years ago
Changing product so that I can request a= for 1.5b.
Status: NEW → ASSIGNED
Component: General → Event Handling
Product: Firebird → Browser
Target Milestone: Firebird0.7 → mozilla1.5beta
Version: unspecified → Trunk
(Assignee)

Updated

16 years ago
Attachment #129497 - Flags: approval1.5b?
Comment on attachment 129497 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to Mozilla 1.5beta.
Attachment #129497 - Flags: approval1.5b? → approval1.5b+
(Assignee)

Comment 25

16 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 26

16 years ago
this bug as described in http://bugzilla.mozilla.org/show_bug.cgi?id=214310 is
still present as of the 20030813 build.
*** Bug 216040 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
*** Bug 216428 has been marked as a duplicate of this bug. ***
bug 214310 seems to be a different issue.

-> VERIFIED Fixed with 2003016 build on W2K
Status: RESOLVED → VERIFIED

Comment 30

16 years ago
Bug 186075 is a dupe of this one.
*** Bug 186075 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
*** Bug 221579 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
*** Bug 222001 has been marked as a duplicate of this bug. ***
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.