Firebird will not build from Mozilla 1.4 sources or CVS as of 7-13-2003. "No rule to make target `export'".

VERIFIED INVALID

Status

()

Firefox
Build Config
--
major
VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: foobarbaz, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Dillo/0.7.2
Build Identifier: n/a

FireBird will not build. I get the same error whether I use Mozilla 1.4 sources or the latest CVS (as of today, 7/13/2003). My build ends like this:

-----
Creating .deps
Creating ../../../../dist/include/xpnet
../../../../config/nsinstall -R -m 644 nsFTPConn.h nsHTTPConn.h nsSocket.h ../../../../dist/include/xpnet
/usr/bin/perl -I../../../../config ../../../../config/build-list.pl ../../../../dist/include/xpnet/.headerlist nsFTPConn.h nsHTTPConn.h nsSocket.h
gmake[5]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/libxpnet/src'
gmake[4]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/libxpnet'
gmake[4]: Entering directory `/usr/src/mozilla/xpinstall/wizard/unix/src2'
Creating .deps
gmake[4]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/unix/src2'
gmake[3]: Leaving directory `/usr/src/mozilla/xpinstall'
gmake[3]: Entering directory `/usr/src/mozilla/toolkit'
gmake[3]: *** No rule to make target `export'.  Stop.
gmake[3]: Leaving directory `/usr/src/mozilla/toolkit'
gmake[2]: *** [tier_9] Error 2
gmake[2]: Leaving directory `/usr/src/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/usr/src/mozilla'
gmake: *** [build] Error 2
fangorn:/usr/src/mozilla# 
-----

I am using Debian/PPC 3.0 (Woody).

Reproducible: Always

Steps to Reproduce:
1. Download Mozilla sources (1.4 or pull from CVS)
2. Follow the FireBird build instructions (i.e. create a .mozconfig with the appropriate options, then go "gmake -f client.mk build")
3. Watch it waste a bunch of your time, then crash 'n' burn.
Actual Results:  
I got frustrated... ;)

Expected Results:  
It should have compiled, dangit.

Please help.
Reporter, first, the 1.4 source tarball doesn't include mozilla/toolkit, since
mozilla/toolkit doesn't do anything for Seamonkey, only for firebird and
thunderbird.  http://lxr.mozilla.org/mozilla/source/browser/README.html mentions
pulling from CVS after defining the .mozconfig file, starting with export
MOZ_PHOENIX=1.  You may want to start with
http://ftp28f.newaol.com/pub/firebird/releases/0.6/MozillaFirebird-0.6-source.tar.bz2
and update your tree from there since that's much faster than pulling the whole
tree.

Downgrading severity to major, although this is probably INVALID.  Without
mozilla/toolkit, its pretty much a lock that Firebird won't compile.
Severity: blocker → major

Comment 2

14 years ago
I have been able to build firebird from the same sources that I use for
Camino. The last time was 0300 this morning.

The About Box has this string: "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.5a) Gecko/20030511 Mozilla Firebird/0.6"

I am not certain that the final build touches the Firebird.app bundle, so I
remark that the Info sheet for Firbird is dated 2003-07-01, which may be a
date of creation (not modification) - the actual Firebird binary does have the
expected date.

Of course, the OP is correct in that compiling Mac Firebird from sources 
by the non-dedicated is probably an indulgence for those with time to burn: 
I do it as Firebird responds to URLs like <URL: chrome://navigator/content >, 
which Camino does not. If there is a big unmet demand for compiling Firebird,
perhaps SKS would draw a list of step by step instructions for doing so from
scratch, and link it to <URL: http://www.mozilla.org/projects/firebird/ >

I would be happy to resolve this as "works for me", I don't think that
it can be closed/written off or whatever, until there are some published
instructions.
Now that I have more knowledge of the matter, I can say for sure you'll get that
error without mozilla/toolkit in your tree.

INVALID, without all of the source, of course it won't compile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 4

14 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.