garageboy.com - page content not shown because of invalid HTML comment syntax

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: jeppe_oland, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Should be a lot of text for each item in the list.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Only see the beginning of the page.

Expected Results:  
Shown the whole page

Comment 1

15 years ago
It's because all the rest of the page content comes after this invalid comment:

<!----------------------------------Beginning of the
FAQ-------------------------------------------->

The broken comment syntax causes Mozilla, in trying to parse what the comment
should be, to comment out the rest of the page.  Comments cannot contain --'s in
the body of the comment itself.

You should write the webmaster and let them know.  You can refer them to the
document at http://devedge.netscape.com/viewsource/2003/comments/ for guidance.

->TE
Assignee: blaker → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Priority: -- → P3
Product: Firebird → Tech Evangelism
QA Contact: asa → english-us

Comment 2

15 years ago
Updating summary.
Summary: None of the info below the menu is showed → garageboy.com - page content not known because of invalid HTML comment syntax
(Reporter)

Comment 3

15 years ago
I wrote the page author.
However other browsers (IE) deal with this problem just fine ...

Updated

15 years ago
Summary: garageboy.com - page content not known because of invalid HTML comment syntax → garageboy.com - page content not shown because of invalid HTML comment syntax

Comment 4

15 years ago
Mozilla will also forgive the bad syntax in old documents that Mozilla renders
in quirks mode.  However, this page has a malformed HTML 4.01 DOCTYPE.  Unknown
DOCTYPEs (which this one essentially is, since it's not one of the 3 valid HTML
4.01 DOCTYPEs) are treated as calling for standards mode rendering by Mozilla. 
In standards mode invalid comment syntax is not forgiven by Mozilla.

The fact that IE or other browsers ignore the bad comment syntax are bugs in
those browsers.
(Reporter)

Comment 5

15 years ago
I guess the decision is between a 100% compliant and pedantic Browser ... or a
forgiving useable one ;-)

Comment 6

15 years ago
Well, even if the author had gotten the DOCTYPE right he'd have the same
problem.  All the 4.01 DOCTYPEs put Mozilla into a non-quirks rendering mode.

Either the HTML should be valid (it's not that far for this page to reach validity):
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.garageboy.com%2Fbmw%2Fbrakefaq.html&doctype=HTML+4.01+Transitional&charset=iso-8859-1+%28Western+Europe%29&ss=1&verbose=1

...or take the DOCTYPE off and just be a quirky document.

Comment 7

10 years ago
Site's fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.