Restricting bug reports to builds of last two weeks -- BAD IDEA

VERIFIED WONTFIX

Status

()

bugzilla.mozilla.org
General
VERIFIED WONTFIX
15 years ago
6 years ago

People

(Reporter: Steve White, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

I just downloaded the latest build of Mozilla (1.4) from your web site.  
dated 2003-06-24. Today it is 2003-7-14.

I tried to file a bug report.  Your browser bug report page tells me

"please do not file bugs on copies of Mozilla older than two weeks."
	
So, we are not to file bug reports on the latest build available from your web site.

So to file a bug report, we must obtain the source by CVS and build the project.

But few people other than developers could pull this off.

Therefore, only developers are to file bug reports.

This indicates a terrible failure to grasp the point of bug reporting.  Perhaps
the usual wrong-headed notion that the program is for and about software developers.


Reproducible: Always

Steps to Reproduce:
1.download latest Mozilla build 2003-06-24
2.try to file a bug report on the browser
3.

Actual Results:  
Web page tells me not to file the bug because my copy is older than 2 weeks.

Expected Results:  
If you feel that must restrict bug reports by software version, make sure an
adequately new binary build is available for users to download.


I think it's a bad idea to restrict bug reports by the age of the software.  A
bug is a bug.  You should collect info about the software version, and decide
what to do about the bug based on that information.

I understand the sentiment that there seem to be too many bug reports.  But this
kind of restriction is the wrong answer to the problem.  Bug reports are good:
so long as adequate info is gathered for database sorting, the more, the better.

The real disasters happen when you get too few bug reports.
Binary builds of current CVS source are available NIGHTLY.

See http://ftp.mozilla.org/pub/mozilla/nightly/latest/


This also has to do with mozilla.org policy, not Bugzilla the software.  Fixing
product so the right people will see it.
Assignee: myk → endico
Status: UNCONFIRMED → NEW
Component: Creating/Changing Bugs → Bugzilla: Other moz.org Issues
Ever confirmed: true
Product: Bugzilla → mozilla.org
QA Contact: matty → myk
Version: unspecified → other

Comment 2

14 years ago
Definitely not a blocker.
IMO this is WONTFIX. We already are swamped with duplicates every day and having
bugs reported against non-current builds makes that only worse.

Leaving open, to let the authorities decide.
Severity: blocker → normal
WONTFIX.

Gerv
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 4

14 years ago
v
Status: RESOLVED → VERIFIED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.