Make menu picks available as toolbar buttons

VERIFIED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
VERIFIED WONTFIX
15 years ago
12 years ago

People

(Reporter: ralph, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030706 Mozilla Firebird/0.6 StumbleUpon/1.66
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030706 Mozilla Firebird/0.6 StumbleUpon/1.66

Inspiration: I was hoping to have a button that I could click to do the
equivalent of View / Increase Text Size.

Suggestion: be able to add a toolbar button for any/most menu picks.

Reproducible: Always

Steps to Reproduce:
1. Right click on toolbar.
2. Select Customize...
3. Review buttons on palette.

Actual Results:  
Various buttons are available, eg ones to correspond to Edit / Cut etc.

Expected Results:  
Various buttons are available, including ones to correspond to most/all menu
picks, including, for example, View / Increase Text Size, or Help / Release Notes.

This could almost certainly be done nicely enough as an extension.

If a menu pick is currently grayed out, a corresponding toolbar button will need
to also be grayed out.

To minimize the graphics work needed to implement this, all the buttons could be
the exact same design. Basically, if someone wants to put any of these buttons
on their toolbar, they need to either use just a handful at most, and rely on
tooltips when they're wondering which is which, or switch text labels on. If a
skin designer has more time, then perhaps there could be multiple button
designs. For example, have an underlined capital V and underlined capital I on
the button corresponding to View / Increase Text Size. Or perhaps "Ctl +". And
so on for other menu picks.
Way too much work for theme authors and I really question the desire to make
EVERYTHING a button.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: General → Toolbars
Resolution: --- → WONTFIX

Comment 2

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Comment 3

15 years ago
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED

Comment 4

12 years ago
*** Bug 324416 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
what is the actual status of this bug, the latest comment was 2003. Is somebody working on it?

Updated

12 years ago
QA Contact: bugzilla → toolbars
WONTFIX means we're not going to do this.
You need to log in before you can comment on or make changes to this bug.