If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IME(Simplified Chinese, Japanese, etc) broken with Flash on OSX

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
major
RESOLVED WONTFIX
14 years ago
9 years ago

People

(Reporter: Peter Lubczynski, Assigned: Peter Lubczynski)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

14 years ago
With simplified Chineses and other asian langages IME input doesn't work
correctly on OSX in Flash form fields. Some input gets inserted but it's the
wrong characters.

Comment 1

12 years ago
URL is not found.

Comment 2

12 years ago
(In reply to comment #1)
> URL is not found.
> 

Use the comment form on this page and you will find the same error.

http://218.83.158.180/temp/index.html

Even though using the Chinese IME, only the correpsonding roman characters are inserted.

Comment 3

12 years ago
(In reply to comment #2)
> http://218.83.158.180/temp/index.html
> 
> Even though using the Chinese IME, only the correpsonding roman characters are
> inserted.
> 
I tried Firefox1.5.0.3 release.
In this version, the input of Japanese is possible. 
(However, a Japanese inline input cannot be done. )
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

But in 1.8branch NB, the alphabet and Japanese are input. 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060525 BonEcho/2.0a2

And in trunk build, Japanese cannot be input. 
Only the alphabet is input as well as Chinese IME. 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060520 Minefield/3.0a1

There might be a possibility that the problem of Flash occurs at time when this bug 
was reported. 
https://bugzilla.mozilla.org/show_bug.cgi?id=98027#c6
http://www.macromedia.com/jp/support/flash/ts/documents/fl0249.html

But now, it might be regression of bug332579 and bug326273. 

Mark-san,
Is the cause understood?

Mac OS X 10.3.9
Summary: Simplified Chinese IME broken with Flash on OSX → IME(Simplified Chinese, Japanese, etc) broken with Flash on OSX

Comment 4

12 years ago
Comment 2 and comment 3 are a new regression, so I'm splitting them off into bug 339346, leaving this bug to handle the original problem, still existing, as reported in comment 0.
looks like this bug is opened for old mac widgets. now, we are using cocoa widget on Fx3 or later.

-> WONTFIX

# the same bug was on them, but it was fixed already.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.