If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Words do not wrap at the end of a line in a box

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English Other
RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: John O'Leary, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: 

At https://escies.org/?login=false, if you resize the window smaller, the text
often overruns the right side of the box.


Reproducible: Always

Steps to Reproduce:
1. Go to https://escies.org/?login=false
2. Make the window smaller
3.

Actual Results:  
The text did not fit in the box.

Expected Results:  
Word wrap without exceeding the box dimensions.

Comment 1

14 years ago
->Layout
But I'm not seeing a problem down to 640x480.
How small are you going, and exactly where is what text showing a problem?
Assignee: general → other
Component: Browser-General → Layout
QA Contact: general → ian
https://escies.org/css/1.css has the line:

.escies-item {width: 100%; margin-top: 0; margin-bottom: 0; margin-left: 2em;
margin-right: 0; padding: 0; border: 0; font-size: 130%;}

which makes those DIVs 100% the width of their parent, with a 2em left margin,
which means they stick out the right edge of the parent by 2em.

The author should just remove the "width: 100%" since "width: auto" is what you
want and is the default.
Assignee: other → english-us
Component: Layout → English US
Product: Browser → Tech Evangelism
QA Contact: ian → english-us
Version: Trunk → unspecified
.
Assignee: english-us → english-other
Component: English US → English Other
QA Contact: english-us → english-other

Comment 4

14 years ago
Confirming per previous comments
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ah, the reporter was the webmaster, and has fixed the problem (per email).
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.