Preferences are not saved once set in Edit ->Preferences

RESOLVED WORKSFORME

Status

SeaMonkey
Preferences
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Philip Limitone, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.4 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When I try to set my preferences, i.e.: not allowing pop-ups, etc., a window 
appears saying that this information will not be saved.  The error message 
that appears in the window is: Failed to save the preferences file.  Any 
preference changes will be lost at the end of this session. 

Reproducible: Always

Steps to Reproduce:
1. Go to Edit -> Preferences
2. Attempt to change a preference.
3. Click OK
4. Error window with message "Failed to save the preferences file.  Any 
preference changes will be lost at the end of this session." appears.
5. Close Mozilla
6. Reopen Mozilla, check preferences, see that they are not saved.
Actual Results:  
The same scenario occurred.

Expected Results:  
Mozilla should have saved the preferences as I have set them under Edit-
>Preferences.
Browser, not Bugzilla.  Just like the text next to the big red stop sign at the
top of the page where you filed this said.
Assignee: myk → ben
Component: User Accounts → Preferences
Product: Bugzilla → Browser
QA Contact: matty → sairuh
Version: unspecified → 1.4 Branch

Comment 2

15 years ago
I am new to this... I don't believe this is a bug.  It said that it could not
save to the preferences file and then didn't.  This was not reproducable by me,
perhaps the user does not have permission to access the preferences file?

Comment 3

15 years ago
I've got the same problem. It happens under Windows XP, when the user is not an
administrator. You cannot change your preferences, you cannot change your
bookmarks. This even if when you create the account, you select a directory on
which you have all the rights. Changing your account type to administrator solve
the problem, but this is not acceptable.

Comment 4

14 years ago
related bug is Bug 205317

Comment 5

14 years ago
Unable to reproduce as user or administrator with Mozilla 1.7 beta on windows
XP. See
http://lxr.mozilla.org/seamonkey/source/xpfe/components/prefwindow/resources/content/nsPrefWindow.js#292
for the code that throws this allert. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.