Closed Bug 212717 Opened 17 years ago Closed 15 years ago

turning headers to all, and making mail view window smaller, can scroll if it gets to small.

Categories

(MailNews Core :: Composition, defect, minor)

x86
Windows 2000
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 223132

People

(Reporter: smaster44, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030712
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030712

I set headers to all, and then made the size of the mail pane very small, small
enough for only a line or two to be displayed. When the size of the pane was
around 4-5 lines, the scroll bar disappeared, buy you could still see the blocks
at the end of the scroll bar.
When you get to 1-2 lines viewable lines, your scroll bar is gone, and you are
unable to move around in the email to read anything.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
To be able to use the scroll bar on the right, or
Bug 184998 is the root cause of this, and of bug 180144.

It is not true that you cannot scroll the mail; as long as any of the message is
visible, you can put the focus on it and use PageUp/PageDown.

See also the somewhat related bug 41994 / bug 167405.
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 184998
My point is that you shouldnt have to go and use the keyboard if you made your
messave view area to small.
The behavior of the disappearing scroll bar or at least the end points is
different than the mail list window just above the message. If you resize the
message list window to as small as you can go (no message list is visible) you
can still see that there is or should be a scroll bar endpoint (though the
graphic for that is a bit under/over the message window border). If you resize
the message window down till both the scroll bar endpoints touch, beyond
that they both disappear.

This behavior isn't serious unless you are aware of what happens to the
message window scroll bar when a message comes in with some very
large header (like when headers->all is on) and your message doesn't
"appear" scrollable. It is a bit shocking for a user and mostly annoying
to the rest of us.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/2003102804
Product: MailNews → Core

*** This bug has been marked as a duplicate of 223132 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
No longer depends on: 184998
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.