When prompted with a Site which requires Username/password, M11 Crashes.

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Andy Sharp, Assigned: Stephen P. Morse)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The Error Message printed by my operating system (NT 2000, Build 2031) is
"Access Denied" on an attempted memory read.


The Site in question is http://www.nector.com/demo/  I entered a
username/password, and then declined the option to have the information saved to
disk.  Upon attempting validation (it seems) the browser then tanked. (no output
to console window)

Now everytime the same url is accessed, the browser crashes before prompting for
uname/passwd.


The OS error is "The instruction at 0x60b409b1 referencef memory at 0x00000028,
the memory could not be read".

I have no idea if debugger output helps, but here's the contents of the initial
debugger output.
60B409B1   mov         dx,word ptr [ecx]


--A

Comment 1

18 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Comment 2

18 years ago
Punting from "Architecture" product back to "Browser".
Assignee: nobody → morse
Component: XPCOM → Single Signon
Product: Architecture → Browser
QA Contact: nobody → sairuh
Version: 5.0 → other
(Assignee)

Comment 3

18 years ago
Is this still a problem (the bug report is almost two months old).  If it is, 
then please provide a username and password that I can use to reproduce the bug 
at this particular site.
(Assignee)

Comment 4

18 years ago
I assume that this particular problem is fixed since I haven't received a reply 
to my question.  There are other bugs with http authentication, but Judson and 
Gagan already have bug reports on those.  So I'll mark this as works-for-me 
since I didn't get a crash.

I'm also changing the component to "networking" (just in case the bug report 
gets reopened) because this is a problem involving http authentication.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Single Signon → Networking
Resolution: --- → WORKSFORME
i don't see the crasher problem, so am gonna verif this one.

however i see another problem, which may or may not be dependent on the URL.
(bug 26149).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.