96%+ processor use when viewing 7dayshop.com

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: mozbugs, Unassigned)

Tracking

({perf, testcase})

Trunk
x86
All
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Any of the catalogue pages at http://www.7dayshop.com cause a huge amount of
processor use (96%+), viewing with either Mozilla 1.4 or Firebird 0.6 on a
PIII-1Ghz with 512MB RAM, WinXP.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.7dayshop.com
2. Wait for the page to redirect into the catalogue
3. Try browsing the catalogue and note the CPU usage
Actual Results:  
CPU use near 100%

Expected Results:  
Much less CPU use

Comment 1

15 years ago
Confirming using trunk build 2003071204 on winxp pro sp1, 1.1ghz, 512ram
Having 100% cpu usage without doing anything.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf

Comment 2

15 years ago
Confirming trunk 2003-07-14-08, Win2k, Athlon 500, ATI Rage 128 GL AGP, 384 MB
RAM. I see 93-100% CPU usage if the URL is the main tab and the images are
allowed to loop as many times as they like.
I get "only" 20-35% CPU with an Athlon 2600+. Time to upgrade your CPU :-)

Comment 4

15 years ago
Im using win2k, using 200307128 and I get no CPU utilization past about 5%

Comment 5

15 years ago
I get about 90% on Linux, with 80% in X and 10% in Firebird.  20030516 on
Slackware 9, PIII 1.13GHz.
OS: Windows XP → All
Whiteboard: MINIMAL TESTCASE NEEDED

Comment 6

15 years ago
Created attachment 127848 [details]
testcase

I have no idea what this thing is, but it's there if the <link> tag's there (in
IE too). The more text in the document, the higher the processor usage. If you
put the code from the stylesheet instead of <link>, it's gone.

Updated

15 years ago
Keywords: testcase
Whiteboard: MINIMAL TESTCASE NEEDED

Comment 7

15 years ago
Hmm under my home machine (Firebird 20030630, WinXP, Dual Athlon XP 1700+, 1GB
RAM, Radeon 9800), there is only about 20% utilization, with most of it as
Kernel time according to taskmgr.  That test case doesn't really case the issue
though, just the original webpage.

Comment 8

15 years ago
I realize that the testcase doesn't take up the processor. But I found "loading"
thingy very odd, so I figure it's the cause.

As I said, as I cut down on text in the file, processor usage got less. There
wasn't anything in particular that caused it.
Looks like almost all the time is spent in painting, due to the animated gifs on
the page....
(Reporter)

Comment 10

15 years ago
Created attachment 128354 [details]
testcase

Still very high processor use with very little left in the file.

Comment 11

15 years ago
I have no problem with that testcase either.
*** Bug 217516 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
Processor use depends on window size. O_o

Appears to be the case with both testcases, too, though on a smaller scale. 

Comment 14

15 years ago
I still get the problem when going o 7dayshop, of 88% processor X, and 4% on
firebird. This is running firebird 0.7, athlon XP3000 on redhat 9

Comment 15

14 years ago
I still see no problem with the testcases or URL in this bug.  Can the people
who saw the problem before test again?

Comment 16

14 years ago
OK - I can't test with the same machine or same version of firefox (or firebird)
right now because that machine doesn't currently have a monitor attached; I've
tested remotely over the network - but that's not really a fair test.

Having said all that:

The site no longer seems to chew up loads of processor time, using either
Firefox 1.0PR or Firebird 0.6 over the network from the old machine.

Interestingly, 7dayshop seem to have removed the loading graphic (which seems to
have been done as a background graphic that gets covered by the page contents,
if that's a useful clue!).

The second testcase referenced the loading.gif file from the 7dayshop.com
website, and this file seems to have been replaced with a single-pixel static gif.

Comment 17

10 years ago
do you still see this?

WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090313 Shiretoko/3.1b4pre
Assignee: layout → nobody
QA Contact: ian → layout

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.