ChatZilla preferences are too big for Preferences window

VERIFIED FIXED

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: vedran, Assigned: rginda)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
ChatZilla preferences are much bigger than Preferences window can show, so some
of them can't be shown.
(Reporter)

Comment 1

16 years ago
Created attachment 127801 [details]
Screenshot

This screenshot shows what happens.
(Reporter)

Updated

16 years ago
Depends on: 198823

Comment 2

15 years ago
-> All/All (OS X)

*really* rough testing shows this happened somewhere between 1.4 and 1.5a... all
themes
OS: Windows XP → All
Hardware: PC → All

Comment 3

15 years ago
robert, do you have any plans / design direction here? I may look at this if I
have time in the next few weeks and see if I can get a clean solution together,
but this is pretty much your thing.

Comment 4

15 years ago
I'd be happy to have a go at this one... there's a few other things I know of
that need tweaking/fixing with prefs, might as well do them in one go.

Comment 5

15 years ago
*** Bug 216247 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

15 years ago
Silver and I discussed this briefly on #chatzilla the other day.  It's going to
be a big change, but I'd like to drop the current pref panels in favor of a
(mostly) generated pref editor done as an .html file in a chrome url.

http://www.hacksrus.com/~ginda/chatzilla/pref-chat.txt

Comment 7

15 years ago
Created attachment 129942 [details] [diff] [review]
quick XUL patch

This is a quick patch against cvs (cz 0.8.34). As discussed with rginda on IRC
this is just a simple removal of the "What does this mean" help option in the
first group in the pane.

This gets its so all the prefs are seen and (at least on os x classic & modern)
things look just fine.

Didn't remove any of the scripts or gut this any deeper then the XUL file as I
expect it to be a somewhat temporary fix.

Comment 8

15 years ago
Created attachment 129943 [details]
screenshot with patch applied

a screenshot with the patch applied.. OS X/Modern Skin

Comment 9

15 years ago
Look fine on Linux (helvetica, 12pt)

Default character encoding should be empty dropdown, I suppose.
(Assignee)

Comment 10

15 years ago
The chatzilla 0.9.x branch has landed on the trunk and should be available in
tomorrow's nightly build.  If you believe this bug has not actually been fixed,
please repoen it.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

15 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

15 years ago
Created attachment 131428 [details]
Screenshot with Modern Theme

When using Modern theme, bar still gets cut. This doesn't really matter for
preferences, because coding can still be selected, so it's design-only issue.
I don't know if it's important or not.

Comment 13

15 years ago
Ummm... this is still not fixed in the suite. Using current trunk builds with
Classic theme on Win XP it looks pretty much like in the last attachment added
above.
Bug 226305 is related.

I know the upcoming new prefs window may/does fix this by completely rearranging
things, but it's not currently in Mozilla and this bug might have to be fixed
for 1.7 (or even later) independently from what happens on the chatzilla
development trunk.

Reopening.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 14

15 years ago
As of 1.7 RC2 this problem still exists in Win2k in modern and classic themes,
the bottom border of character encoding is still cut off.  Should be fixed so
Mozilla looks more professional.
(In reply to comment #14)
> As of 1.7 RC2 this problem still exists in Win2k in modern and classic themes,
> the bottom border of character encoding is still cut off.  Should be fixed so
> Mozilla looks more professional.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616] (release) (W98SE)
and
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520] (release) (W98SE)

In W98SE, Classic, too.
Depends on: 218070

Updated

15 years ago
No longer depends on: 218070
(Reporter)

Comment 16

15 years ago
Chatzilla got new preferences window and this bug no longer exists.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Reporter)

Updated

15 years ago
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.