Closed Bug 21277 Opened 21 years ago Closed 21 years ago

chrome files missing (broken symlinks)

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: colin, Assigned: bugs)

Details

Pulled M12 code yesterday, found that 4 links in my dist/bin tree don't actually
go anywhere:

chrome/navigator/content/default/contentframe.xul
lives in mailnews/base/resources/content, but makefile doesn't install it.
makefile over in xpfe/browser/resources/content/ tries to install it (but
he doesn't have the file).

chrome/navigator/skin/default/contentframe.css
makefile in xpfe/browser/resources/skin/ tries to install it, but the
file doesn't exist in that directory (or anywhere that I could find it).

chrome/sidebar/locale/en-UN/panel-add-confirm.dtd
lives in xpfe/components/sidebar/resources/locale/en-US
xpfe/components/sidebar/resources/Makefile.in tries to install it
from en-UN directory instead of en-US

chrome/sidebar/locale/en-UN/panel-exists.dtd
Same as above
reassigning to hyatt for triage. Dave, who is responsible for these?
Assignee: trudelle → hyatt
Assignee: hyatt → slamm
Giving to a browser person.
Status: NEW → ASSIGNED
Target Milestone: M13
I will clean them up.
Assignee: slamm → rgoodger
Status: ASSIGNED → NEW
Target Milestone: M13 → M15
Move to M15.  We don't have to fix this for beta 1, do we?
Doesn't need fixing for beta unless those files are actually meant to be in the
kit. I don't know the answer to that one. I presume they are probably not
otherwise something would be broken, right???
dunno about that panel-add stuff (en-UN? United Nations? -- looks like a typo).

but contentframe.* refers to an older version of the sidebar that is no longer
in use. If someone would school me on how to remove files from the CVS server,
I'd kill them.
They need removing from the build before they are removed from CVS.
Status: NEW → ASSIGNED
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
This problem doesn't occur any more. Feel free to close.
cool! thanks for the update, colin!
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
marking as verified then
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: paulmac → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.