mozilla.org does not validate

RESOLVED DUPLICATE of bug 212795

Status

RESOLVED DUPLICATE of bug 212795
15 years ago
6 years ago

People

(Reporter: jacksmall, Assigned: endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030525 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030525 Mozilla Firebird/0.6

According to http://validator.w3.org/check?uri=http%3A%2F%2Fmozilla.org%2F the
new mozilla.org front page doesnt validate.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Only eight easy to fix errors:

# Line 11, column 10:  required attribute "TYPE" not specified.
      <style>

# Line 16, column 60: required attribute "TYPE" not specified.
      <script src="http://bugzilla.mozilla.org/quicksearch.js"></script>

# Line 19, column 59: there is no attribute "MARGINWIDTH".
    <body background="/frontpage/background.png" marginwidth="0" marginheight="0">

# Line 19, column 76: there is no attribute "MARGINHEIGHT".
  ...ground.png" marginwidth="0" marginheight="0">

# Line 20, column 31: there is no attribute "HEIGHT".
      <table width="100%" height="100%" cellpadding="0" cellspacing="0">

# Line 77, column 26: end tag for element "LI" which is not open.
                        </li>

# Line 177, column 25: required attribute "TYPE" not specified.
                    <script>

# Line 295, column 120: there is no attribute "BORDER".
  ...onclick="this.form.submit();" border="0"></td>


Adding type="text/javascript" to the two scripts takes care of them.  Adding
type="text/css" takes care of it.  Removing marginwidth and marginheight and
adding a little html, body { margin:0px } takes care of that.  Etc.

But is this a dupe of bug 151557 ?
other bug is newer, but it has a patch.

*** This bug has been marked as a duplicate of 212795 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.