Browser selects wrong item in Choice after a Browser "Back"

RESOLVED DUPLICATE of bug 182157

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 182157
15 years ago
15 years ago

People

(Reporter: Ray Sanders, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624

When a Choice has multiple possible selections that have the same meaning (such
as A1, B, A2, C, A3), the user selects "A1", goes forward a page, then back, the
browser selects a different Choice item with the same meaning (usually the last
item in the Choice with the same meaning). In this contrived example it would be
"A3". This is not a show stopper, but is an annoyance from the perspective of
doing a double-take when a different (and less recognizable) item is selected
after the "Back".

Reproducible: Always

Steps to Reproduce:
1. go to the USPS International Rate Calculator
2. select "Package"
3. pick a country that has multiple entries (i.e. UK or Japan)
4. Enter some weight
5. click "Continue"
6. click on the Browser back icon
Actual Results:  
A different entry is shown in the country Choice. It is actually for the same
country, but not the one that I selected. It is usually (probably always) the
last item in the Choice for that country. For example, selecting "Great Britian"
results in "Wales (Great Britian and Northern Ireland)" being selected after the
Back click.

Expected Results:  
Should have redrawn with the same item selected in the Choice.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 181257 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Whoops.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 182157 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.