File | Save Page As: remove "Page" -> "Save As.."

VERIFIED FIXED in M18

Status

SeaMonkey
General
P3
trivial
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: cpratt, Assigned: Chris McAfee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-]fix already in trunk)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID: 1999120808
Platform: all

To reproduce:
- Launch Mozilla
- Select File | Open File
- Open a local image file (eg /res/arrow.gif)
- Drop down the File menu

Result: Note that what used to be called "Save As" is now "Save page as". I
don't think that this is correct. Why?
- "Save As" is what we used in previous versions of Communicator
- "Save As" is the de facto standard in IE, OE, Office, etc
- "Save page as" doesn't make sense when viewing things other than pages (such
as image files)

I suggest this be changed back to "Save As..." (note the capitalization too).
(Reporter)

Updated

18 years ago
QA Contact: elig → sairuh

Comment 1

18 years ago
German?

Updated

18 years ago
Assignee: shuang → german

Comment 2

18 years ago
If it is already speced out,then do whatever the spec says for now. Re -assign
it to german to make final decision in the pec details if it hasn't speced out.

Comment 3

18 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Comment 4

18 years ago
I checked with German. Use "Save As...".  Please reassign this bug to the 
correct engineer to be implemented.

Comment 5

18 years ago
Please assign to correct engineer to be implemented.
Assignee: german → don

Comment 6

18 years ago
Reassigning to Ben and setting target milestone to M20.
Target Milestone: --- → M20

Comment 7

18 years ago
Move to M21 target milestone.
Target Milestone: M20 → M21
(Assignee)

Comment 8

18 years ago
*** Bug 39958 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
UI, ben.  Easy, one-liner.
Assignee: don → ben
Summary: File | Save page as doesn't make sense in many contexts → File | Save Page As: remove "Page" -> "Save As.."
(Assignee)

Comment 10

18 years ago
mcafee
Assignee: ben → mcafee
(Assignee)

Comment 11

18 years ago
Created attachment 11193 [details] [diff] [review]
patch
(Assignee)

Updated

18 years ago
Keywords: patch
Target Milestone: M21 → M18
(Assignee)

Comment 12

17 years ago
fixed on trunk, rtm branch frozen
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
the patch was checked in the trunk --why not check it into the branch as well?
nominating for rtm, and reopening to get pdt's attention. if pdt won't approve,
then re-resolve this and add relnoteRTM (sigh).
Status: RESOLVED → REOPENED
Keywords: rtm
Resolution: FIXED → ---
another question for mcafee. with this change, how is the menu affected when
viewing frames? right now (ie, viewing a page w/frames w/branch bits), there's
now Save Page As... and Save Frame As... in the File menu.
(Assignee)

Comment 15

17 years ago
I don't have a good answer for the frames scenario.
Save As... means "Save everything you see as" as it is
checked in right now.  How do you save a Frame Set?
Maybe we should grey out Save As for the frames case.
(Assignee)

Comment 16

17 years ago
I don't think this is an rtm issue, it's a UI nit.
We shouldn't be checking nits into the branch.

Comment 17

17 years ago
Minus.  Won't hold RTM for this.
Whiteboard: [rtm-]
Whiteboard: [rtm-] → [rtm-]fix already in trunk
(Assignee)

Comment 18

17 years ago
marking fixed, this is not landing onto the branch.
We should file a new bug for the frames case.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
verified in the trunk [2000.10.11.08] on linux. not marking vrfy till it's
finally checked in to the branch (ie, not sure if during the post-rtm fun this
will go into a branch, or just stay in the tip *sigh*.)

also filed bug 56540 for the frames case (unfortunately in that one, the
behavior differs btwn Mac and win32/unix).
vrfy'ing for the trunk. 2000.11.21.08 winnt [and linux], 2000.11.21.13 mac.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.