Duplicate (triplicate?) newsgroups scan

VERIFIED DUPLICATE of bug 72318

Status

MailNews Core
Networking: NNTP
--
minor
VERIFIED DUPLICATE of bug 72318
15 years ago
9 years ago

People

(Reporter: Bertrand Denoix, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When I expand/collapse repeatedly a newsgroups tree in the left side panel, its
seems a newsgroups scan is launched for each expansion, so I get several scans
running in parallel (this shows in "Checking newsgroup X of Y" display in the
status bar, where X obviously comes from two different sequences.

For reproducibility, I believe a slow speed connection (56K modem) and
reasonably high number of subscribed newsgroups (>50) is necessary.

Reproducible: Always

Steps to Reproduce:
1.Expand a newsgroup server
2.Collapse it
3.Re-expand it
4.Go to 2 

Actual Results:  
Status bar displays, in that order:
Checking newsgroup 56 of 72
Checking newsgroup 12 of 72
Checking newsgroup 57 of 72
Checking newsgroup 13 of 72
....



Expected Results:  
Aborted the first scan before starting the second, or ignored the second.

Comment 1

14 years ago
confirming tbird 20031211 Win2k.

*** This bug has been marked as a duplicate of 72318 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.