All users were logged out of Bugzilla on October 13th, 2018

A secure session expires automatically

RESOLVED EXPIRED

Status

()

RESOLVED EXPIRED
16 years ago
13 years ago

People

(Reporter: pk_joshi, Assigned: darin.moz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030624

Today I have downloaded the Mozilla 1.4 version and tried to access a secure
site (a banking site). The main page asks me to enter userd ID and passwd and on
clicking submit it takes me to my current statement page. So far so good. Now on
clicking account reconcillation tab (or Previous statement tab) it just throws
me out of the secure session by showing a new page which asks me to select a
service offered by e-statement. Selecting the relevent option takes me to the
main (or the first) page and again asks me to enter the username/password.

Clicking back button takes me to the current statement page.

I was using 1.4b in the morning and it was working perfectly.

Reproducible: Always

Steps to Reproduce:
In case you have an account with e-statement.
1. Go to https://www.e-statement.com/microdynamics/CU3601400/frame/Frame.htm
2. Enter User Id and password. This will show the current statement.
3. Client Account reconcilation tab or previous statement Tab.
4. Press back button.

Actual Results:  
It takes me to the logout page and shows a pull down menu to selct services
offered by e-statement.com.

The back button also takes me to the last page accessed (current statement).

Expected Results:  
Should have showed a pull down menu to select the period for previous statements.

The back button should show me the screen where I need to enter login/password
and then it should take me to the current screen.

This page was working with 1.4b.
(Reporter)

Comment 1

16 years ago
Created attachment 127872 [details]
Mozilla log file for the e-statement session.

This log file captures my session with e-satatment. Please use Winzip to unzip
the file.
Ca you please try it again with a new profile ?
(Reporter)

Comment 3

16 years ago
This problem is coming even with a new profile. Netscape 7.1 with a new profile 
also shows the same output ("Actual Results").

As I had mentioned that Mozilla 1.4b is working fine, please let me know in 
case you need the log file for the same session with e-statement using Mozilla 
1.4b.
(Reporter)

Comment 4

15 years ago
I tried to compare the HTTP requests for e-statement in Mozilla 1.4b (working) 
and Mozilla 1.4 (not working). All the requests are same except one GET 
request. 

  GET /ibilling.sph/microdynamics.class/MainServlet HTTP/1.1

The strange part for this request is the referer field is same as the request 
itself.
Referer: https://www.e-
statement.com/ibilling.sph/microdynamics.class/MainServlet

I made a debug build from the latest trunk on 2nd June to find out who is 
initiating such a request. Here is the call stack for this request:

nsHttpChannel::Init()
nsHttpHandler::NewProxiedChannel() 
nsHttpsHandler::NewProxiedChannel()
nsIOService::NewChannelFromURI()
NS_NewChannel()
NewImageChannel()
imgLoader::LoadImage()
nsImageLoader::Load()
nsPresContext::LoadImage(nsPresContext * const 0x035d1b80, const nsString & 
{"https://www.e-statement.com/ibilling.sph/microdynamics.class/MainServlet"}, 
nsIFrame * 0x0375bd38, imgIRequest * * 0x0012f014)
nsCSSRendering::PaintBackgroundWithSC()
nsCSSRendering::PaintBackground()
nsFrame::PaintSelf()
nsHTMLContainerFrame::PaintSelf()
nsHTMLContainerFrame::Paint()
CanvasFrame::Paint() 
PresShell::Paint() 
nsView::Paint()
nsViewManager::RenderDisplayListElement()
nsViewManager::RenderViews()
nsViewManager::Refresh()
nsViewManager::DispatchEvent()
HandleEvent(nsGUIEvent * 0x0012f77c)

1. Why this page (or request) is assumed as a background image 
(nsCSSRendering::PaintBackground) ? The content type returned in the reposne 
header is text/html.

2. The request finally gets cancelled because the content type is text/html 
("imgRequest::OnDataAvailable -- Decoder not available").

It seems to me a problem related to either style sheet handling (The e-
statement page has a style sheet "styles.css") or while painting the page it by 
mistake generates a request for background image. I even tried to compare the 
mozilla\layout\html directory in Mozilla 1.4b and the latest trunk (on 2nd 
June) but the differences are too many for a novice like me to make anything 
out of them.

My suggestion is to assign some expert to verify the changes made (enhancements 
or any bug fixes) between 1.4b and the 2nd June in the layout section. I am 
willing to spend time to fix the bug but know nothing about the style sheets or 
painting of pages. Although I have done some work in the HTTP protocol section. 
Please provide some pointers from where I can start finding the exact cause for 
this problems.

Thanks and Regards
-Pawan

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.