[Regression] Cards display incorrectly in addressing bucket of Select Addresses dialog

VERIFIED FIXED in M12

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: esther, Assigned: hangas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using build 1999120808m12 on linux only, card names are displayed as "undefined"
<undefined> in the addressing bucket of the Select Addresses dialog.

1. Launch Messenger
2. Click New Msg to bring up a Compose window
3. Click the Address button to bring up the Select Addresses dialog
4. Select an address book, select a card then click the To: button

Result: an entry in the addressing bucket displays the card as "undefined"
<undefined>, and when OKing the dialog the names are not transferred to the
addressing area of the compose message window
Expected: the card name to correctly display in the addressing bucket.
(Reporter)

Updated

18 years ago
Summary: [PP]linux only, regression cards display incorrectly in addressing bucket of Select Addresses dialog → Regression cards display incorrectly in addressing bucket of Select Addresses dialog
(Reporter)

Comment 1

18 years ago
UPDATE:  this did not happen on the win32 or mac yesterday, but now it does.
Removing the [PP] in the summary
(Reporter)

Updated

18 years ago
OS: Linux → All
Hardware: HP → All
(Reporter)

Comment 2

18 years ago
Changing platform and OS to all
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Regression cards display incorrectly in addressing bucket of Select Addresses dialog → [Regression] Cards display incorrectly in addressing bucket of Select Addresses dialog
Target Milestone: M12
(Assignee)

Comment 3

18 years ago
This is due to the name changes in the address book api.  I have the fix in my
tree now.  If I get permission to check it in, I can fix this.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
Fix checked in.

Updated

18 years ago
QA Contact: lchiang → esther

Comment 5

18 years ago
On Mac commercial seamonkey build 1999-12-10-08-m12, it no longer displays
<undefine> in the bucket.

But when you click OK, it fails to transfer the the addresses to the compose
addressing pane.  Nothing shows up.  Laurel found this problem true and win32
and Linux.  She is logging a separate bug.  I think we should keep the address
name in the bucket and the transfering the names to the addressing pane
separate.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Using build 1999121321 on win98 and build 1999121320 on linux and build
1999121314 on mac this is fixed (both problems).  Verfified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.