circular/invalid dependencies of rh8 rpms

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: kelly felkins, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: INVALID)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4/contributed/Red_Hat_8x_RPMS/gtk2/RPMS/i386/

I try to install mozilla-1.4-0.i386.rpm, and I get "Package Not Found:
mozilla-nspr=37:1.4=0 required by mozilla"
I try to install mozilla-nspr-1.4-0.i386.rpm, and I get "Package Not found:
mozilla-nspr=1.0.2-1.8.0 required by mozilla-nss".
For kicks, I try to install mozilla-nss-1.4-0.i386.rpm, and I get Pacakge Not
Found, mozilla-nspr=37:1.4-0, required by mozilla-nss.

As background, I am running RH 8.0, and I uninstalled the original mozilla rpms
before I tried to install 1.4.




Reproducible: Always

Steps to Reproduce:
1. On rh8, using the gui package manager, uninstall mozilla
2. as described in "details"
3.

Actual Results:  
previously described in details

Expected Results:  
It should have installed.

Comment 1

15 years ago
I noticed this bug too on Red Hat 8.  I'm a linux newbie (of sorts) but I
eventually gave up, because it was clear Mozilla was not going to get installed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
>Blocker: This bug prevents you from testing or developing Mozilla.

Seems to fit.  I'm sure when this is triaged it might get it's severity downed.
Severity: minor → blocker
doesn't block Mozilla development (use the installer builds)

-> blizzard
Assignee: general → blizzard
Severity: blocker → major

Comment 4

15 years ago
download all Mozilla 1.4 RPMs
rpm -Fvh mozilla*
or
rpm -e mozilla-whatever
rpm -ivh mozilla-nss-1* mozilla-nspr-1* mozilla-1*

you can't install them one at a time.

> As background, I am running RH 8.0, and I uninstalled the original mozilla 
> rpms before I tried to install 1.4.

if the old ones were gone, you wouldn't get messages like
"mozilla-nspr=1.0.2-1.8.0 required by mozilla-nss".
rpm -qa | grep mozilla
Whiteboard: INVALID
Product: Browser → Seamonkey

Comment 5

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 6

8 years ago
We don't ship RPMs for trunk builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.