link with CSS hover and p:first-line causes link text inside <p></p> tags to repeat itself

RESOLVED DUPLICATE of bug 177539

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 177539
15 years ago
15 years ago

People

(Reporter: Henry Wong, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

<html>
<head>
<style type="text/css">
p:first-line {
  margin-left:10em;
}
a:hover {
  background-color:#000000;
}
</style>
</head>
<body>
<p>aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa
aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa aaaaa <a href="link">linktext</a></p>
</body></html>

The link text ("linktext" above) will repeat itself every time the mouse cursor
is moved away from the text and back (i.e. cause the hover background to change)
if :
1. the window is small enough such that word-wrapping causes the link to be on
the third line of the window or below. (i.e. a small window)
2. The page was reloaded (Ctrl+R) with the mouse cursor pointing at the text
preceding the link (i.e. "aaaaa"). Other methods can also cause the problem, but
this is one way it can be reproduced consistently.

Problem occurs in (at least) Mozilla 1.3.1/WinXP, Mozilla 1.4/Win2k, Mozilla
1.3.1(?)/Mandrake Linux, Phoenix (0.5?)/Win98...

(also, Mozilla 1.4 appears to ignore p:first-line -> margin-left...)

Reproducible: Always

Steps to Reproduce:
1. load above page, containing p:first-line and a:hover in a CSS sylesheet. Text
followed by a link needs to be within a <p> </p> block.
2. resize window so word-wrapping places link on third line of text or below.
(not first nor second lines)
3. position mouse cursor on text before link.
4. press Ctrl+R
5. move mouse cursor over link and away from link repeatedly.

Link text should duplicate itself every time the mouse hovers over it, with
alternating black and white background-colors (color as specified by stylesheet).

The p:first-line->margin-left and a:hover->background-color attributes aren't
actually necessary. (But p:first-line and a:hover are.) 

Actual Results:  
Link text should duplicate itself every time the mouse hovers over it, with
alternating black and white background-colors (color as specified by stylesheet).

Expected Results:  
Link text should not duplicate itself!

*** This bug has been marked as a duplicate of 177539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.