Mozilla is selecting application/x-java-vm from http://wp.netscape.com/plugins/jvm.html but fails to install, repeats until forever!

VERIFIED DUPLICATE of bug 202952

Status

()

Core
Plug-ins
--
major
VERIFIED DUPLICATE of bug 202952
15 years ago
14 years ago

People

(Reporter: Helge Larsson, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030716
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030716

Still problem selecting correct java plugins that is working with Debian or
Redhat    Linux, An referense where to download and show what build is done with
eather gcc-2.95.4 or gcc-3.x! Missing appropriated link to download with
installation instructions instead of direct installation...
By manually install the plugins with a link from sun's java homepage, got it
working with Redhat and Suse with (gcc-3.x) j2sdk-1.4.2-nb-3.5-bin-linux.bin.
The installation is failed on Debian probaply due to gcc-2.95.4 diffrency.
http://wp.netscape.com/plugins/jvm.html 

Reproducible: Always

Steps to Reproduce:
1.Enter any URL that require Java. 
2.It notice missing application/x-java-vm and try to install it from
http://wp.netscape.com/plugins/jvm.html

Actual Results:  
1.Eather if you are running as root (should be able to install but is dangerous)
or normal user (always failing due to missing write access).
2 Installation is allways failing. 
3.Above way is wrong way to install java plugins, it does not show where the
downloaded plugins is located so next time it is downloading the failed plugins
again and again. Have no clue where both the plugins is stored or installed.
4.Trying to download Jre or Jdk from sun has only success with Redhat and Suse
with j2sdk-1.4.2-nb-3.5-bin-linux.bin but fails to run on Debian. Haved tryed
with j2re-1.4.1_03-fcs-linux-i586.rpm but is both complaining on undefined symbols.

Expected Results:  
Selecting correct application/x-java-vm plugins, download it and show a
installation description (or execution through a installation script).
Also possible to install the software NOT as root both mozilla and the plugins!
Whiteboard: DUPEME
(Reporter)

Comment 1

15 years ago
Also got Debian installation to work by manually perform following steps
1. Install it on Suse or Redhat by execute the bin file j2sdk-1.4.2...bin
2. This is stored at /opt/j2sdk_nb directory, 
   # cd / && tar czvf j2sdk_nb.tar.gz /opt/j2sdk_nb
3. Untar the tared file on Debian
   # cd / && tar xzvf j2sdk_nb.tar.gz
4. Create a symbol link 
   # ln -s
/opt/j2sdk_nb/j2sdk1.4.2/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so .

5: Still wrong directive to install the j2re or j2sdk plugin received from
netscape's web page. 





*** This bug has been marked as a duplicate of 202952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.