bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Greek Entities α, β, γ and possibly others rendered improperly



Core Graveyard
GFX: Gtk
15 years ago
9 years ago


(Reporter: Robert Uhl, Assigned: blizzard)


Firefox Tracking Flags

(Not tracked)





15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Instead of rendering as alpha, beta and gamma, the entity references render as
very odd characters in a script unknown to me.

Reproducible: Always

Steps to Reproduce:
1. Create a page with the HTML references mention above.
2. View said page (this is on a Red Hat 9 system, rebranded as Pink Tie 9).
Actual Results:  
I see the odd, non-Greek characters.

Expected Results:  
Displayed the appropriate Greek lowercase characters (looking like an alpha, a
beta and a gamma).

Comment 1

15 years ago
the alpha/beta/gamma display fine for me on linux (1.4 and trunk 20030716)
with a different profile, the characters looked different, but were still
recognizable.  you might try a clean profile.
Are you using an xft build?  A freetype2 build?  A normal build?

Comment 3

15 years ago
I see this problem, too.  I use the Greek capital omega symbol (among others)
when writing about electronics.  ("Ohms" symbol.)  I have tried fixing it by
using different ways of referring to the entity (upper and lower case, Unicode
value vs. readable name (Ω vs. Ω)) and changing the default browser font.

This affects the RPMs distributed from the Mozilla.org servers.  I don't know if
they are xft or freetype based, but I do know this started when these new font
system builds started becoming available.  Back when the distributed RPMs used
regular ("aliased"?) fonts, Greek characters were displayed properly.

A page that uses these symbols is:
http://tangentsoft.net/audio/ppa/amp/pguide.html  Skip down to the sections
describing the various resistors used in this circuit.

Notice that the lowercase mu character used up in the capacitor description
sections is displayed properly.  This suggests that it's a font problem, or
perhaps an incomplete character set mapping problem.
The RPMs are xft-based.

Just for completeness, I am not seeing the problem with a non-xft (nightly
tarball) build, and if it's just xft builds showing the problem this bug needs
to be reassigned... 

Comment 5

15 years ago
worksforme with linux trunk CVS/xft/gtk2.  the gamma looks a little strange, but
is still a gamma.

Comment 6

15 years ago
I still see this on the contributed RH9 RPMs for 1.5rc2 on ftp.mozilla.org. 
I've made a new page that shows this: http://tangentsoft.net/moztest.html  The
URL I gave in my previous comment and the URL given by the original submitter
also show this problem.

Some Greek letters are correctly rendered, and others use near-equivalents from
the Phoenician alphabet, like "B" for capital beta.
OK, over to blizzard.  Everyone seeing this bug, please list the version of XFT
you have installed.
Assignee: general → blizzard
Component: Browser-General → GFX: Gtk
QA Contact: general → ian

Comment 8

15 years ago
Xft has been integrated into XFree86 4.3.0.  I'm running on Red Hat Linux 9.0
with their XFree86 4.3.0-2 RPMs installed.  Gtk2 is v2.2.1, for what that's worth.

Comment 9

15 years ago
If someone can provide me a test (which is sort of included here), what it looks
like in your version and what it's supposed to look like, it would go a long way
to helping to fix it.

Comment 10

15 years ago
I've added two screen-grabs to the tangentsoft.net page whose URL is given
above.  The Win32 one is correct, the Linux is partially correct.  I can try
other fonts if you like, but this problem exists with all of the ones I've
tried.  I haven't installed any fonts beyond what came with my system, and I
haven't tried all that I have on the system yet.

Comment 11

15 years ago
Yeah, there's just a lot on those pages.  I was hoping for something that was
reduced to just the characters in question.

Comment 12

15 years ago
I've pared my tangentsoft.net test page down to two rows: one for Alpha, where
the upper case is the same as the Phoenician 'A', and the other for Omega, where
neither case looks like a Phoenician letter.  Windows Mozilla renders all four
characters correctly.  Linux Mozilla only renders upper-case Alpha correctly.

I also upgraded both of my test systems to v1.5 binaries downloaded from
mozilla.org before taking these frame grabs.

Comment 13

15 years ago
The most recent test page looks fine on my machine, which uses gtk2+xft and
happens to be running Fedora Core.

Comment 14

15 years ago
  I have seen several differences on different platforms for html code 

RedHat-8.0 Linux (Stock) with Mozilla-1.4 build 20030701 downloaded from
  In the page, tab title, and window title I get a capital Sigma followed by a
box with 0394 inside it.

Solaris-8 with Mozila-1.5 built from source 20031126 (using fontconfig-2.2.90,
freetype-2.1.5rc1, and xft-2.1.2):
  In the page and tab title I get a capital Sigma and capital Delta.
  In the window title I get a capital Sigma and the box with 0394.

In Internet Explorer-6.0 it works in all places (just using it for reference).

  How can I fix this problem both on my RH-8.0 and Solaris-8 boxes?  I
appreciate any help!

Comment 15

14 years ago
Has there been any progress on this issue since the last comment?

I still see the error when using

Firefox 0.9.1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

but not when using

Mozilla 1.7
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

All this under Red Hat 9, as in the original description.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.