All users were logged out of Bugzilla on October 13th, 2018

browser will correct triple slash syntax in <a href

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: sime, Assigned: darin.moz)

Tracking

Trunk
All
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030605
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030605

Browser will not return error if inappropriate number of slashes are entered in
an URL. Not dependant if the link is clicked, or entered manually in the
location bar. I dont believe correcting the number of slashes applies to any
standard.

Reproducible: Always

Steps to Reproduce:
On a web page example
W1. Goto URL provided, click link [A0] (one slash used)
W2. Click links [A2,3]. Where three and four slashes are used
W3. Click links [B0,2,3]. With the variation of the protocol is used.
Links [A1] and [B1] are syntactically correct. 

Manual entered example.
M1. Goto location bar, type http:/www.google.com/
Actual Results:  
W1. Now at http://www.google.com/
W2. Now at http://www.google.com/
W3. Now at ftp://ftp.mozilla.org/

M1. Now at http://www.google.com/

Expected Results:  
W1. Incorrect syntax error.
W2. Incorrect syntax error.
W3. Incorrect syntax error.

M1. Incorrect syntax error.

Should also note I used Mozilla Composer to create http_slash_Bug_Example.html
> M1. Goto location bar, type http:/www.google.com/

This is done on purpose.  No, its's not part of a standard. But it's more
user-friendly to treat it as a pretty obvious typo in the URL bar than to throw
error-messages, and the standard explicitly says that it may be treated as such
if desired.

> W1. Now at http://www.google.com/

That's not actually what I see us doing (current Linux trunk build).  Odd, since
single-slash ftp: does go to mozilla.org

Over to networking, ccing the url-parsing folks.
really reassign...
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc
(Assignee)

Comment 3

16 years ago
ok, so under linux things seem perfectly normal.

http:/www.google.com/ is mapped to a relative URL, whereas ftp:/ftp.mozilla.org/
is treated as an absolute URL.  that's because the base URL has scheme http:, so
we treat the first URL as a non-standard relative URL (for website compatibility).

now, if i try the example from windows...

everything is similarly as expected.

marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.