Status

()

Firefox
General
--
trivial
RESOLVED INVALID
15 years ago
11 years ago

People

(Reporter: Werner Flamme, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I'm reading the SAP R/3 manuals - quite boring stuff ;-)

The source code tells Firebird: <font FACE="Symbol">&#174;</font>. This means an
left arrow, my charmap tells me. This makes sense ;-)

Firebird instead shows &#210; or &#226; instead (can't tell the difference, same
sign in my charmap). This sign is an (R). This makes no sense ;-)

Bug or feature (if text too boring, put s.th. inside to attract the user's
attention)?

Reproducible: Always

Steps to Reproduce:
1. looking at the text
2. looking at the source code
3. comparing source with charmap

Actual Results:  
I notice that the source tells the browser to show a left arrow. Firebird shows
the (R) sign instead.

Expected Results:  
Firebird should show the correct char of the font.

Changing the theme does not change the effect. As said, the charmap tells me
that the character requested by the source (the left arrow) has the given code,
so my font file seems to be OK.

Comment 1

15 years ago
Werner, can you please download a current nightly build and verify this issue
with this build and a fresh profile?
Summary: Wrong character shown → Wrong character shown

Comment 2

15 years ago
I believe character 174 is in the Windows-only range (128 - 256) of characters
that is excluded from Unicode and most other character sets.  That is likely the
problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.