amretgrp.com - Form does not POST when I click "Add to Order" submit button

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
15 years ago
4 years ago

People

(Reporter: dmaillet, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

In the page at
http://ems.amretgrp.com/products/product_detail.jsp?PRODUCT%3C%3Eprd_id=845524441770681&FOLDER%3C%3Efolder_id=282574488340217,

there is an "Add to Order" button.  It is an INPUT tag with type "image" and a
value of "Submit".

After clicking this button, the page reloads, rather than submitting the Form.


Reproducible: Always

Steps to Reproduce:
1. Go to the URL 
2. Click the "Add to Order" button


Actual Results:  
The same page reloads

Expected Results:  
A shopping cart should have appeared (which it does under IE 5 and IE 6)
(Reporter)

Comment 1

15 years ago
The HTML page had an additional value="Submit" element in the input tag.  Once
this element is removed from the page, then the problem goes away as well.

<input type="image" name="add" src="button.gif" value="Submit" border="0">
Evang.  If I recall correctly, IE has a bug that prevents it from submitting the
value of image inputs, while mozilla submits it...
Assignee: form-submission → english-us
Status: UNCONFIRMED → NEW
Component: Form Submission → English US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: ashishbhatt → english-us
Hardware: PC → All
Version: Trunk → unspecified

Updated

15 years ago
Summary: Form does not POST when I click "Add to Order" submit button → amretgrp.com - Form does not POST when I click "Add to Order" submit button

Comment 3

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.