Rapidly clicking the "file" menu option cause it to fail to respond

VERIFIED DUPLICATE of bug 17042

Status

()

Core
XUL
P2
normal
VERIFIED DUPLICATE of bug 17042
18 years ago
10 years ago

People

(Reporter: andreww, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
1) launch Mozilla (Commercial)
2) rapidly click on the file option in the "file edit view" menu.

Expected Results:
The file menu options hide and show as toggled.

Actual Results:

eventually (after about 10 or so clicks) the file menu will stop responding and
stay "closed".

Other observations:
If the window loses focus and then regains it - the the menus seem to respond ok
again - until you rapidly click them again.

The time interval it takes to get this behavior varies from 2 - 20 rapid clicks.
There doesnt seem to be an exact number or speed to achieve this.

Havent tested this in Linux, but since mac menus are different, they do not
display this behavior.
(Reporter)

Comment 1

18 years ago
I also noticed that if you get the menu to fail to respond, no other click
events will fire as well, so you cannot browse links click buttons, etc.

Updated

18 years ago
Assignee: trudelle → saari
Priority: P3 → P2
Target Milestone: M13

Comment 2

18 years ago
Reproduced on Win98.  You can recover by clicking on another window, then
clicking back. Most people will treat the app as having crashed though.
assigning to saari as p2 for M13

Updated

18 years ago
QA Contact: paulmac → sairuh

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
*** This bug has been marked as a duplicate of 17042 ***
Status: RESOLVED → VERIFIED
verified as dup.

Comment 5

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.