View source window is always maximized, no matter what window state Mozilla is in when called

RESOLVED INVALID

Status

defect
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: bernzilla+bugs, Assigned: doronr)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

I typically run Mozilla in a non-maximized state since my screen resolution is
set fairly high.  Any time I open a new Mozilla window it respects my current
setting and opens the new window with the same dimensions as the one I'm
currently using.

However, this is not so with View Source.  When I choose Page Source from the
View drop-down menu, the window that pops up is always maximized.  It is my
opinion that the Page Source window should follow the same etiquette that new
windows do.  So, if Mozilla is maximized, the Page Source window should be too,
but if not, the Page Source window should appear at the same dimensions of the
parent window that opened it.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla in a non-maximized state (open and focused, but not taking up
the whole desktop).
2. Select View, Page Source
3. Notice that the Page Source window is maximized, taking up the whole screen.

Actual Results:  
Page Source window is maximized, taking up the whole screen.

Expected Results:  
Page Source window has the same dimensions of the parent window that opened it.
The view-source window remembers its state.  So if you size it to the size you
want, it will keep that size thereafter.  Did you maximize it at some point?
Reporter

Comment 2

16 years ago
You're correct, it does remember its state.  I must have maximized the window at
some point a long time ago and it has remained that way since.  Sorry for any
wasted time.
Resolving invalid because it wasn't a bug in the first place :).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey

Updated

9 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.