incorrectly placed context menu on <object type="text/html> with "position:fixed"

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: YH Huang, Assigned: roc)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030711
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030711

at given url (http://128.148.60.60/mozbug/object.html), 4 boxes are shown, two
of them (red ones) are <obejct type="text/html" data=...> tags, and when
right-clicking on either of them, popup menu is not under the cursor.

Reproducible: Always

Steps to Reproduce:
1. goto http://128.148.60.60/mozbug/object.html
2. right-click either of the red boxes
3.

Actual Results:  
Those boxes are given "position: fixed" css style. The popup menu seems to be
offset the same amout from the cursor as the box is offset from the viewport
origin, i.e. if box is fixed at "left: 100px; top: 100px", then the menu would
be 100x100 pixels away from the cursor.

Expected Results:  
Menu should be placed right where the mouse cursor is.

Bug exists in both Linux and win32 nightly.
"position: absolute" text/html object is ok; "position: fixed" image/png is ok;
iframe is ok.
(Reporter)

Comment 1

15 years ago
Eh, just noticed, text in the lower-left box (position: absolute;
type="text/html") can not be selected. Or should I be able to?

Comment 2

15 years ago
confirming using 2003071604 on Win2k.
Assignee: other → jaggernaut
Component: Layout → XP Toolkit/Widgets
Keywords: testcase
QA Contact: ian → jrgm

Comment 3

15 years ago
related to bug 132782?
This is probably related to the broken style context setup <object> HTML stuff
ends up with....
I can fix this.
Assignee: jaggernaut → roc+moz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: incorrectly placed context menu on <objcet type="text/html> with "position:fixed" → incorrectly placed context menu on <object type="text/html> with "position:fixed"
The testcase has disappeared. The bug was probably fixed by my checkin for bug
242833.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.