Bug in the page design when its W3C html 4.0 and CSS compatible

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
French
--
major
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Martin Samson, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Well if you look at: http://rpgportal.webdynamit.net/hackquebec/ with Internet
explorer, everything look fine, but with mozilla firebird its all screwed up. I
don't know why because my page is a complete valid html 4.0 (with the w3c test)
and valid css (also with w3c)

Maybe there is a little problem with the css in mozilla firebird ?


Also, its not the only CSS website to bug like that with mozilla.

Reproducible: Always

Steps to Reproduce:
Just go to http://rpgportal.webdynamit.net/hackquebec/ with mozilla firebird




Actual Results:  
well the page is all screwed up because mozilla firebird cant take a valid CSS

Expected Results:  
Should have show the page with no bugs in the design (the code is perfect)

Comment 1

15 years ago
This is not Firebird specific.
->Layout
Assignee: blakeross → other
Component: General → Layout
OS: Linux → All
Product: Firebird → Browser
QA Contact: asa → ian
Version: unspecified → Trunk

Comment 2

15 years ago
The left side menubar is off because IE uses margin to do the default
indentation of lists (which your CSS overrides with your values), and Mozilla
uses padding (which is not overridden by anything in your styles, so you get
margin and padding pushing the lists out).  Simply adding padding: 0 to your UL
and OL default definitions and the problem goes away.  Also see
http://devedge.netscape.com/viewsource/2002/list-indent/ for a guide to
cross-browser list indentation.

The next paragraph over (class edito) needs a z-index: 1 applied to get it to
appear on top, instead of covered by the left menu.  I think that is expected
behavior and what IE is giving is buggy, but I could be wrong.

The highlighted lines at the start of each item in the main body are correct
because of an IE bug only.  Those items (class newstitre) are defined as height
: 3px, so that's exactly what Mozilla is giving you.  IE is expanding the height
to contain your content, which is taller than 3px.  This is certainly incorrect
behavior and an IE bug.  A classic example of how code that validates to the
validator does not automaticaly mean an author is using it to the correct effect....

The DIV containing those items (class newse) needs a z-index as well to fix the
rendering, so that it's atop the header graphic and not vice versa.

That's all the difference I see between the two browsers.  Unless we are doing
something wrong with the DIVs that need a z-index to match the IE rendering,
nothing on this page is a Mozilla bug.  Several things are in fact IE bugs.
->Evang.
Assignee: other → french
Component: Layout → French
Product: Browser → Tech Evangelism
QA Contact: ian → french
Version: Trunk → unspecified

Comment 4

15 years ago
Conirming new.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
The site has changed, http://rpgportal.webdynamit.net/hackquebec/ does no more
exists. The homepage http://rpgportal.webdynamit.net/ is mainly ok with Firefox 0.8.
WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.