Last Comment Bug 2133 - [PP]Jan25:Mac freezes waiting for data
: [PP]Jan25:Mac freezes waiting for data
Status: VERIFIED FIXED
:
Product: NSPR
Classification: Components
Component: NSPR (show other bugs)
: other
: PowerPC All
: P1 critical (vote)
: ---
Assigned To: gordon
: glynn
Mentors:
http://www.cnn.com
: 2199 2303 2430 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1998-06-16 07:00 PDT by Mike Pinkerton (not reading bugmail)
Modified: 2000-03-22 13:30 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Mike Pinkerton (not reading bugmail) 1998-06-16 07:00:00 PDT
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #142690
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=142690
Imported into Bugzilla on 01/04/99 16:10)

Surf for a few pages, and the mac will freeze up in Delay(). What appears is
happening is NSPR is waiting for data (which never arrives), so it goes into an
infinite loop until something arrives, scheduling the main thread, sleeping,
waking up, and rescheduling. This starves out the UI so the mac appears frozen.
Comment 1 don 1998-06-16 11:19:59 PDT
Changing TFV to 5.0 SF1 in.
Comment 2 Wan-Teh Chang 1998-06-17 11:46:59 PDT
*** Bug 124235 has been marked as a duplicate of this bug. ***
Comment 3 Wan-Teh Chang 1998-06-17 12:03:59 PDT
Accepted the bug.

Bug 124235 was marked as duplicate of this bug.

Added sdagley, gagan, and freier to the Cc list.

I am studying the NSPR mac source code now.  Is
there any area that you think is the suspect?

I suspect that PR_Poll may fail to report socket
connection close as a readable event, so we
don't know the download is done.

I also discovered that NSPR's implementation
of nonblocking socket I/O on the Mac is incorrect.
If we always call PR_Poll first and only call
I/O functions when the fd is readable or writable,
then this is probably not a problem.  Gagan, can
you confirm that Netlib always calls PR_Poll
before calling read/recv/write/send on sockets?

I am not familiar with our user-level thread
scheduling code and with Mac, so please be
patient.  I am doing my best to get up to
speed.
Comment 4 Wan-Teh Chang 1998-06-17 12:18:59 PDT
Bug #124235 is a test stopper and a duplicate
of this bug, so I guess this bug is a test
stopper too.

Assigned QA to glynn (same as in bug #124235).
Comment 5 Gagan 1998-06-17 12:58:59 PDT
I am adding Lou to the list. He did the NSPR20 upgrade and might know about
this. Lou?
Comment 6 don 1998-07-15 16:44:59 PDT
jar and I have decided that a fix for the Mac NSPR2 problem is no longer a
requirement for ending the stability freeze so I'm moving the target fix version
of this bug to 5.0.   But Wan-Teh, Gordon, and Joe should continue with fixing
this bug as their top priority.
Comment 7 gordon 1998-08-31 17:45:59 PDT
Taking bug for Wan-Teh
Comment 8 gordon 1998-08-31 17:51:59 PDT
*** Bug 299777 has been marked as a duplicate of this bug. ***
Comment 9 Mike Pinkerton (not reading bugmail) 1999-01-11 11:47:59 PST
*** Bug 2199 has been marked as a duplicate of this bug. ***
Comment 10 Mike Pinkerton (not reading bugmail) 1999-01-12 13:46:59 PST
*** Bug 2303 has been marked as a duplicate of this bug. ***
Comment 11 leger 1999-01-14 12:37:59 PST
This bug is slowing down our ability to do Mac testing greatly.  What's the
status on a fix?
Comment 12 gordon 1999-01-15 16:20:59 PST
*** Bug 2430 has been marked as a duplicate of this bug. ***
Comment 13 leger 1999-01-17 12:34:59 PST
gordon...whats the eta for some headway on this one?  thanks!
Comment 14 leger 1999-01-18 10:38:59 PST
Adding URL info.
Comment 15 leger 1999-01-25 16:16:59 PST
I just played with Jan 25 Mac build and it looks better.  What do you think
elig?
Comment 16 gordon 1999-01-26 15:42:59 PST
The flaw in the Mac NSPR socket implementation is still there. I've been out sick
for the past week, but this is my number one priority now.
Comment 17 Eli Goldberg 1999-01-26 18:10:59 PST
Thanks, Gordon. <Purely anecodotally, Viewer doesn't seem to be crashingly nearly
as often as a result of this particular problem on the more recent builds,
believe it or not.>
Comment 18 leger 1999-02-03 07:15:59 PST
Inserting Milestone info.
Comment 19 leger 1999-02-03 08:03:59 PST
Setting all current Open Critical and Major to M3
Comment 20 Paul MacQuiddy 1999-03-05 23:10:59 PST
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Comment 21 glynn 1999-03-12 18:33:59 PST
Gordon status on this puppy?
Comment 22 leger 1999-03-13 15:54:59 PST
elig, can you try this with the latest Apprunner Mac build please.  Win32 Mar13
build loads this URL ok.
Comment 23 don 1999-03-13 18:23:59 PST
Resolved as FIXED.

Gordon checked in the stuff, so ... :-)
Comment 24 glynn 1999-03-14 19:28:59 PST
Whoo Hoo! Will check Monday morning :-)  Changed to make myself, glynn as qa
contact.
Comment 25 glynn 1999-03-15 17:58:59 PST
As far as I can tell this puppy appears fixed.  March 15 builds.  Marking
verified, will reopen if necessary.
Comment 26 Mike Pinkerton (not reading bugmail) 1999-03-16 09:32:59 PST
I got this just this morning on the tinderbox page (lockup in _Delay during
networking). I don't think it was waiting for DNS lookup (which is still
synchronous). Reopening bug. I really am terribly sorry, gordon.
Comment 27 don 1999-03-16 10:16:59 PST
Well ... crap.

Grodon, is Mike on something or is it really back?
Comment 28 don 1999-03-16 16:48:59 PST
Resolved bug as FIXED.

Since Pink or glynn can't reporduce the failure ...
Comment 29 glynn 1999-03-17 13:24:59 PST
Reverified until a reproducible example of new failure can be found.
Comment 30 Terry Weissman 1999-04-27 10:59:59 PDT
NSPR now has its own Bugzilla product.  Moving this bug to the NSPR product.

Note You need to log in before you can comment on or make changes to this bug.