Closed Bug 213304 Opened 17 years ago Closed 17 years ago

hover pseudo-element behavor depends on mouse direction when used with adjacent sibling selectors

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 15608

People

(Reporter: 92222, Assigned: saari)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714 Epiphany/0.7.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714 Epiphany/0.7.3

the page basicly contain this html:

    <div class="level-1">first div</div>
    <div class="level-1">second div</div>
    <div class="level-2">third div</div>

and the following styling:

div + div.level-2 {
        color: #00f;
        background: #fff;
}
div:hover + div.level-2 {
        color: #00f;
        background: #000;
}
.

Whin entering the second div with the mose from the third div, the hover effect
works, but if you enter from the first div it dosen't

Reproducible: Always

Steps to Reproduce:
1. load testcase
2. move the mousepointer slowly from the bottom of the page to the top
3. move the mousepointer down again
4. now move the pointer outside the window to above it.
5. slowly move down

Actual Results:  
At step 2 the content of the red box turns black, and at step 3 white again.
At step 5 this change to black dosen't hapen as it should.

Expected Results:  
Turned the box black.
Forgot to say that it also occurs in 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714
(ie. not epiphany)

*** This bug has been marked as a duplicate of 15608 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.