Large increase of refcount leaks on brad

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: mvl, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

The brad tinderbox shows a huge increase in refcount leaks, and an increase in
trace malloc leaks.
The timeframe doesn't show any interestinh checkins. cc-ing people that checked
in in a somewhat wide timeframe.
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=&branchtype=match&date=explicit&mindate=07%2F19%2F2003+14%3A00&maxdate=07%2F19%2F2003+18%3A00&cvsroot=%2Fcvsroot

I really don't know what caused this, so dumping it in browser-general for now.

Comment 1

15 years ago
My checkin was to add a new file that is used only
if you are building Mozilla on Linux 2.6 kernels.
Since brad is Linux 2.4, the refcount leaks could
not have been caused by my checkin.
The leak log has:

--NEW-LEAKS-----------------------------------leaks------leaks%-----------------------
GlobalWindowImpl                                456          -
nsShutdownObserver                               56          -
PageCycler                                      224          -
nsXBLDocGlobalObject                             24          -
nsSystemPrincipal                                60          -
nsCookieService                                  88          -
nsHttpHandler                                   300          -
nsDOMClassInfo                                  112          -
nsEventQueueServiceImpl                          56          -
NavigatorImpl                                    24          -
nsObserverService                                12          -
nsCodebasePrincipal                              72          -
nsProxyEventObject                               96          -
nsNSSComponent                                  376          -
nsRDFResource                                    48          -
nsDNSService                                    116          -
nsPrefService                                    44          -
nsNetModRegEntry                                 64          -
nsObserverList                                  280          -
RDFServiceImpl                                  268          -
nsNetModuleMgr                                   20          -
nsStringBundle                                   36          -
nsJSRuntimeServiceImpl                           20          -
nsExceptionService                               56          -
nsSSLStatus                                      28          -
nsCStringKey                                    560          -
nsPrefBranch                                    128          -
nsCookieHTTPNotify                               12          -
nsHashtable                                     308          -
nsThread                                         24          -
nsSharedPrefHandler                              84          -
nsXPCWrappedJSClass                              40          -
nsTimerImpl                                      96          -
nsEventQueueImpl                                 32          -
nsSupportsArray                                1560          -
nsWindowDataSource                               72          -
nsVoidArray                                      88          -
nsDOMSOFactory                                   16          -
nsXULPDGlobalObject                              24          -
nsPref                                           44          -
nsCharsetMenuObserver                            12          -
nsProxyObjectManager                            100          -
nsEntropyCollector                             1044          -
nsNSSCertificate                                 36          -
ContentShutdownObserver                           8          -
nsCacheSession                                   84          -
nsP3PService                                     12          -
nsHttpConnectionMgr                              80          -
nsPluginHostImpl                                 96          -
nsCookiePermission                               12          -
nsSocketTransport                               176          -
XPCNativeScriptableInfo                          64          -
nsBrowserInstance                                28          -
nsLocalFile                                     580          -
nsPersistentProperties                           84          -
nsProxyObject                                    96          -
xptiInterfaceInfo                               160          -
nsStreamTransportService                         16          -
nsGenericFactory                                 16          -
nsHashKey                                       188          -
nsSimpleURI                                       4          -
nsNSSSocketInfo                                  92          -
nsFtpProtocolHandler                             36          -
nsXPCWrappedJS                                   44          -
nsProxyEventClass                               288          -
XPCWrappedNativeProto                           224          -
nsSocketTransportService                       1296          -
nsPermissionManager                             100          -
nsAggregatePrincipal                             92          -
nsIOService                                      72          -
nsHttpConnection                                 88          -
XPCNativeScriptableShared                       608     700.00%
XPCWrappedNative                                308     600.00%
nsXPCComponents                                 176     300.00%

So it looks like we're just leaking the world.... And no, there are no checkins
in that range that I can see that would do this....

Comment 3

15 years ago
could it be a checkin that doesn't show up under SeaMonkeyAll? (i looked at ipc
already, it's not that. nss perhaps... doubtful, but...?)

is there a good way to search cvs logs for the entire tree (i.e. without
searching around for file-modified times in my local tree)?
um, SeaMonkeyAll contains everything, no? It definitely includes NSS (I've seen
NSS checkins there)
SeaMonkeyAll definitely doesn't contain everything.  MozillaTinderboxAll is
closer, but also doesn't.  There's no way to tell, for example, when the
NSS_CLIENT_TAG is pushed.

However, the easy way to answer the question here is to look at the build log
and see what files were pulled.

Comment 6

15 years ago
The log shows that no files were pulled.
it turns out, when I was mentioning SeaMonkeyAll, I was actually talking about
the "All files in the repository" entry in the bonsai listbox...
(Reporter)

Comment 8

15 years ago
IT seems to have magicly gone away. Again, without any checkins that I can see,
that could have caused this
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=&sortby=Date&date=explicit&mindate=07%2F31%2F2003+9%3A00&maxdate=07%2F31%2F2003+12%3A30&cvsroot=%2Fcvsroot

so worksforme, as i don't see what fixed this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.