UI: Remember toolbar expand/collapse state

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: trudelle, Assigned: mscott)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Having the message headers in their own sandbox means that they don't scroll
with the message as you read past them, as they do on  4.x (and Eudora).  They
always take up an inch or so of very valuable vertical real estate, most of
which is blank. This reduces the space available for looking at messages
content, the primary purpose of that window.  Sure, you can minimize the waste
by closing their toolbars, but they are automatically reopened on the next
message. Should I file a separate bug on that?

Updated

19 years ago
Assignee: phil → hangas
Summary: Message headers waste screen space. → Remember toolbar expand/collapse state

Comment 1

19 years ago
The issue with scrolling the headers with the body is covered in bug 9942. We
have a bunch of bugs for remembering UI state (bug 17799, bug 21125, bug 20446
etc.) but none for the toolbars specifically. So, if you don't mind, I'll morph
this bug into "remember toolbar expand/collapse state"

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Target Milestone: M13 → M15

Updated

19 years ago
QA Contact: lchiang → nbaca

Comment 2

19 years ago
*** Bug 21842 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Whiteboard: ui

Updated

19 years ago
Summary: Remember toolbar expand/collapse state → UI: Remember toolbar expand/collapse state

Comment 3

19 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 4

19 years ago
Not beta2 stopper.  Marking M18.  Please let me know if you disagree.
Target Milestone: M16 → M18

Comment 5

19 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 6

19 years ago
reassigning to mscott since he's doing the message pane.
Assignee: putterman → mscott

Updated

19 years ago
Keywords: ui
OS: other → All
Hardware: Other → All
Whiteboard: ui
(Assignee)

Comment 7

19 years ago
this doesn't meet our beta3/rtm criteria.
Target Milestone: M18 → Future

Comment 8

18 years ago
THis works for me with 031205 linux, win32 and mac mozilla builds.  collapsing
the headers by clicking the grippies works and is persisted across mail sessions.  
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

18 years ago
Somewhere along the way the original problem I reported has been lost. All of
the duped and morphed bugs have been resolved, but the undesirable behavior
still remains: space devoted to headers reduces message display space, since
they don't scroll out of the way (as they did in 4.x). Has someone decided that
is wontfix?

Comment 10

18 years ago
- I found two bugs on the issue of the message pane scrolling problem. Bug# 
32055 has the address widget appear to the left/beginning of the addresses. Bug# 
56825 states that this appears too complicated in the short term.

- Marking Verified Worksforme, for the Remember toolbar expand/collapse state
Build 2001-03-23-15: NT4
Build 2001-03-23-21: Linux RH 6.2
Build 2001-03-23-10: Mac 9.04
The toolbar expand/collapse state is remembered for the mail session. It's also 
remembered after a restart in all cases if the browser is also closed (known 
problem with some mail prefs not being saved unless the browser is also open).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.