Downloads non standard file types as txt files. Does not allow user to switch to all file types.

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
16 years ago
2 years ago

People

(Reporter: bryan_hoff, Assigned: law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714 Mozilla Firebird/0.6

I often have to download some non standard file types and the download manager
ONLY allows me to download them as .txt files.  This should default to all files
or at least let the user change file type.

This is always repeated on file extentions of .dld and others.  

Reproducible: Always

Steps to Reproduce:
1.  Try to dl a .dld file or unknown file type.
2.  Try to change file type
3.

Actual Results:  
downloads file as txt file not type specified.

Expected Results:  
At least allow the user to change file type to all files.  Use all files as
default download file type.

Work around : Use another browser (IE?) to dl particular file.
This is not the correct component. This probably belongs to file handling. It 
may also be INVALID; your server is most likely sending "Content-Type: 
text/plain" in the HTTP headers for these files, and we are honoring that MIME-
type.
Assignee: blakeross → law
Component: Download Manager → File Handling
It's invalid because you get this only if the server told Mozilla that the file
is a text file.

Example for a misconfigured server:
http://www.mversen.de/mozilla/text/mozilla.rar

correct server setting :
http://www.mversen.de/mozilla/rar/mozilla.rar


And yes, this works in IE but this is a wanted (?) bug in IE. IE violates the
RFC with this wrong file handling..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.