Closed Bug 213464 Opened 17 years ago Closed 17 years ago

Adjacent sibling selector ignores siblings pseudo-classes.

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 15608

People

(Reporter: sanderb, Assigned: dbaron)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030611 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030611 Mozilla Firebird/0.6

The adjacent sibling selector (
http://www.w3.org/TR/REC-CSS2/selector.html#adjacent-selectors ) ignores any
pseudo-class of the preceding sibling. For example, the following piece of CSS
fails:

a:hover + div {
  background-color: red;
}

also see the testcase i quickly created.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.cs.vu.nl/~sgbouwhu/bug-testcase.html .
2. Hover your mouse over the link.
3. Watch the black-bordered div.

Actual Results:  
The appearance of the div remained the same.

Expected Results:  
It's background should turn red.

*** This bug has been marked as a duplicate of 15608 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.