hang if I launch this xml file

VERIFIED DUPLICATE of bug 197956

Status

()

Core
XSLT
--
critical
VERIFIED DUPLICATE of bug 197956
15 years ago
13 years ago

People

(Reporter: chris, Assigned: peterv)

Tracking

({hang})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

The browser crashes when trying to via this wurfl.xml file. When I had the
problem I was trying to access the file locally (from a downloaded copy). I've
uploaded that exact copy of the file to http://chrisedwards.ca/wurfl.xml because
sourceforge appears to be having problems right now (can't connect to that site).

Reproducible: Always

Steps to Reproduce:
1. Launch http://wurfl.sourceforge.net/wurfl.xml
2. Watch in hang
3. Go grab a Coke or something

Actual Results:  
The browser hangs.

Expected Results:  
Showed me the XML file with pretty formatting.

IE6 on the same machine displays the file perfectly.
(Reporter)

Comment 1

15 years ago
Wow, I should really do quick sanity check on my spelling before I submit :).

Anyways:

"The browser crashes when trying to via this wurfl.xml file."

What I was trying to say is:

The browser crashes when trying to access the wurfl.xml file via the URL
mentioned, or from a local copy.
Looks like an xslt issue -- every time I break during the infinite loop we seem
to get into, I'm somewhere in xslt....
Assignee: heikki-bugzilla → peterv
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: XML → XSLT
Ever confirmed: true
Keywords: hang
OS: Windows XP → All
QA Contact: ashishbhatt → keith
Hardware: PC → All
Summary: crash if I launch this xml file (hangs then needs to be closed via taskmanager) → hang if I launch this xml file

Comment 3

15 years ago
almost 400k of XML is not as bad as almost 700k, but this is the same thing.
XSLT is too slow, big XML files are needing too much mem on prettyprinting.

Jonas, should prettyprinting bail on data starting from a well guessed and 
arbitrary size?

*** This bug has been marked as a duplicate of 197956 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.