status types and status change rules stored in the database.

RESOLVED DUPLICATE of bug 101179

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 101179
15 years ago
6 years ago

People

(Reporter: Jason Pyeron, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: 

Date: Wed, 23 Jul 2003 12:07:10 -0400 (EDT)
From: Jason Pyeron <jason@pyeron.com>
Reply-To: developers@bugzilla.org
To: Bugzilla Dev List <developers@bugzilla.org>
Subject: more flexibility?...

Developers,

In my morning meeting we were talking about storage of finite-state
automata in a RDBMS / XML setting. This got me thinking about how bugzilla
has "hardcoded" status and status change rules.

How receptive would the community be to storing these rules in the
database? This could lead to a more versatile Bugzilla, since new states
could be added with rules (w/o hacking code)


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
alter table products add column defaultstatus int default 1 not null;

create table statusstatetypes
(
 id int primary key not null auto_increment,
 name varchar(64) not null,
 notes text,
 unique (name)
);
insert into statusstatetypes (name) VALUES ('UNCONFIRMED');
insert into statusstatetypes (name) VALUES ('NEW');
insert into statusstatetypes (name) VALUES ('ASSIGNED');
insert into statusstatetypes (name) VALUES ('REOPENED');
insert into statusstatetypes (name) VALUES ('RESOLVED');
insert into statusstatetypes (name) VALUES ('VERIFIED');
insert into statusstatetypes (name) VALUES ('CLOSED');


create table statusstates
(
 id int primary key auto_increment not null,
 name varchar(64) not null,
 type int not null,
 properties varchar(255) null,
 notes text,

 unique (name)
);

create table statusstategraph
(
 state int not null,
 cond varchar(255) null,
 next int not null,

 primary key (state,next)
);

Comment 2

15 years ago
Marking as dup of bug 101179.

*** This bug has been marked as a duplicate of 101179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
boo, bug 101179 has become stale and has no patches.

moving my notes there, and reinventing the wheel.

will be back tomorrow to drop some code patches in.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.